Showing results for 
Search instead for 
Did you mean: 

How to auto-provision Brocade switches by DHCP

New Contributor II
Going through the documentation (which is pretty shoddy) I can't seem to figure this out. My best guess, from what I've read, is:
  • Unzip firmware distribution into TFTP server root
  • Add option 66 pointing to DHCP server (e.g.
  • Add option 67 pointing to manifest file (e.g. FI08070a_Manifest.txt)
  • Reboot switch

However, after getting a DHCP address there are no attempts by the switch to download the manifest file (but it does try to download a config file.) How does this work?

New Contributor II
I just configured this in my lab and it worked like a champ. I have an ICX-7150 running 8.0.61a and the following configuration on an ICX 7150-C12 as the DHCP server. I am using TFTPd on my laptop as the TFTP server.

vlan 420 by port                                                  
 untagged ethe 1/1/8 
 router-interface ve 420
ip dhcp-server enable
ip dhcp-server pool autoprovision
 bootfile FI08070a_Manifest.txt
 lease 0 0 15
interface ve 420                                                  
 ip address

New Contributor II
Hmm, very frustrating, that's exactly the setup I'm using (although not on a Brocade DHCP server.) My TFTP server is the same machine as the default gateway. I've tried a few variations such as option 150 instead of 66, and still no luck. Thanks for going through the trouble though!

As for why the config gets downloaded, I know the switch defaults to pulling a config from its gateway, so my hunch is that the TFTP server address included in the DHCP reply is being ignored completely by the switch. This would possibly explain why it doesn't even try to download the manifest file.

It's a shame you aren't able to pull a packet trace since it's just a switch-to-switch communication. There must be something different getting sent by the Brocade DHCP server.

Just noticed you were asking about DHCP server config, but as I said I do not use switches for DHCP serving. Here's what a reply looks like:

Client-Ethernet-Address 78:a6:e1:2d:d8:c6
Vendor-rfc1048 Extensions
Magic Cookie 0x63825363
DHCP-Message Option 53, length 1: Offer
Server-ID Option 54, length 4:
Lease-Time Option 51, length 4: 6721
Subnet-Mask Option 1, length 4:
Default-Gateway Option 3, length 4:
Domain-Name-Server Option 6, length 4:
TFTP Option 66, length 10: ""
TFTP-Server-Address Option 150, length 4:
BF Option 67, length 21: "FI08070a_Manifest.txt"

New Contributor II
Try changing the default gateway to something else since you are on the same switch and it is not needed. Set option 66 to your PC since it is the tftp server. What are you using for your DHCP server?

New Contributor II
My PC is not a TFTP server, my router is; it's also my DHCP server.

New Contributor II
My PC is not my TFTP server, my router is (and is also my DHCP server.) I tried setting up TFTP on my laptop in case the Brocade didn't like them being the same address, but no change.
I think the only thing left to try is setting up one Brocade as a DHCP server like you've done, and grabbing a packet trace via port mirroring to see why it works! Very frustrating that all the documentation is so vague or factually incorrect.
Thanks for your assistance though!