cancel
Showing results for 
Search instead for 
Did you mean: 

Configuring an enable password on ICX7450 in 9.0

frnkblk
New Contributor III

I scoured the documentation but could not find it -- how do I configure an enable password in version 9.0? Every time I SSH into our switches and go into enable mode I get a warning:

SSH@router>en
No password has been assigned yet...
SSH@router#

Frank

1 ACCEPTED SOLUTION

I believe that is referring to the following 8.x command:

device# configure terminal
device(config)# aaa authentication enable implicit-user

This command is deprecated in 9.x

BenBeck_0-1659719072873.png

 

Ben Beck, RCNA, Principal Technical Support Engineer
support.ruckuswireless.com/contact-us

View solution in original post

4 REPLIES 4

BenBeck
Moderator
Moderator

Hey @frnkblk 

You will need an authentication method list for enable. If you are using local database, it would look like this:

SSH@ICX(config)#aaa authentication enable default local

If you are coming from 8.x releases, there are a lot of changes in authentication with 9.x. The 9.0 release notes will list new, modified and deprecated commands. The respective guides would then have the details on said new commands. 

Ben Beck, RCNA, Principal Technical Support Engineer
support.ruckuswireless.com/contact-us

frnkblk
New Contributor III

Thanks -- that kind of worked, but I get asked for a username as well.

root@nagios:/tmp# ssh username@<redacted-IP>
Password:

SSH@router>enable

Login:username

Password:
SSH@router#

Is there a way to just have an enable password?  The documentation says this (emphasis added),

If enable authentication is configured on the device, when a user attempts to gain Super User access to the Privileged EXEC and global configuration levels of the CLI, by default the device prompts for a username and password. You can configure the device to prompt only for a password. The device uses the username entered at login, if one is available. If no username was entered at login, the device prompts for both username and password.

I do have username at login, as you can see from the output I shared, but it still asks for a username.

I believe that is referring to the following 8.x command:

device# configure terminal
device(config)# aaa authentication enable implicit-user

This command is deprecated in 9.x

BenBeck_0-1659719072873.png

 

Ben Beck, RCNA, Principal Technical Support Engineer
support.ruckuswireless.com/contact-us

frnkblk
New Contributor III

Thanks -- another 9.x documentation item to clean up