Showing results for 
Search instead for 
Did you mean: 

Can't Update ICX7150-C12P to 09.0.10

New Contributor III


I've got an ICX7150-C12P running SPR08095m.bin (UFI)

When I try to upgrade to 09.0.10 via

copy tftp flash ICX7150/SPR09010dufi.bin primary
...lots of output, but no errors
copy tftp flash ICX7150/SPR09010dufi.bin secondary
...lots of output, but no errors
boot system flash primary

I get

Extract UFI FI version success, version = SPR09010d.bin
New packages found, uninstalling old packages if any..
Installing packages, this may take some time
Packages has been installed successfully
ln: /lib/ File exists
ln: /lib/ File exists
ln: /lib/ File exists
ln: /lib/ File exists
ln: /lib/ File exists
starting console application
ln: /lib/ File exists
ln: /lib/ File exists
cp: can't stat '/.pkg/libpam/etc/*': No such file or directory

And after another reboot, the switch is stuck in a (re)bootloop

mv: write error: Structure needs cleaning
mv: can't preserve times of '/fast_iron/.tmp/FastIron': Read-only file system
mv: can't preserve ownership of '/fast_iron/.tmp/FastIron': Read-only file system
mv: can't preserve permissions of '/fast_iron/.tmp/FastIron': Read-only file system
BI FS error occurred, hence rebooting the system. if same issue happens after reboot, please do power-cycle the system, in order to recover
ln: /FastIron: File exists
/etc/ line 633: can't create /fast_iron/.hash_track.md5: Read-only file system
Requesting system reboot
[  227.540368] reboot: Restarting system
[  227.584266] Asserting GHPIO[7] reset sequence from Kernel ...


Is this a known issue? Sadly I don't have a support contract (I would like to buy one though, but you're not selling it to me).

Any ideas? I have been able to reproduce this error multiple times (recover to 08.0.90mc -> Upgrade to 08.0.95m -> Works -> Upgrade to 09.0.10 -> Failure)

I have tried multiple versions of 09.0.10, like 09.0.10d, 09.0.10h or 09.0.10j


RUCKUS Team Member

Hi GreensTheorem,

Thank you for posting your query !!!

I understand that you got an ICX7150-C12P running SPR08095m.bin (UFI) and you are facing issue when you try to upgrade to 09.0.10 the unit got stuck in a boot loop.

I have a question for you here :

A>Have you tried to upgrade via USB/PENDRIVE if not can you get it a shot.

Make sure the USB is in FAT32 format

copy firmware files in the USB and insert USB in the switch

run the below commands :
mount disk0
show files disk0
copy disk0 flash SPR09010dufi.bin primary
write memory
boot system flash ( where we upgraded the unit ) primary / secondary

Then copy flash flash primary ( to copy the secondary to primary )

Please refer the below link for usb upgrade:

B>Any specific reason for upgrading to 9010d, Are you looking for any specific feature set in 9010d firmware. The reason why we are asking because the current recommend firmware version is 08095m. 

If your unit is stuck in boot loop you can recover via software recover as shown in the below link.

Even if the issue is not resolved after software recovery then RMA is the last option.

Please log a ticket with the below link so that we will help you to process RMA

NOTE: Please confirm us if you are from Lennar homes

I hope this information helps you

Please feel free to leave us a message if any concerns

RUCKUS Team Member

Hi GreensTheorem,

Thank you for reaching us. 

Adding to the post. From the details mentioned looks like you have copied 9010d to primary and secondary flash. Before you try software recovery once try to boot the switch from secondary flash using below command from boot OS and check if the unit is booting up or still stuck in boot mode.

ICX7150_boot> boot_secondary

If the switch is still in boot loop then when you are trying to use software recovery method please try to also flash and check with SPR08095m version if software recovery with 9010d version fails.

I hope the details shared with you in both posts help you fix the problem.