Showing results for 
Search instead for 
Did you mean: 

Unleashed R310 AP - Upgrade Needed

New Contributor II
Hi Everyone, 

Need some help .. I have a customer who has a Ruckus Unleashed setup .. 

there are currently 6 x R310 running in there office .. 

One is the "master" the others are members .. I was doing my 6 month updates on them when I ran into this issue .. 

As normal I logged into the "master" ap and went to "admin & services" then to "administration" and clicked on upgrade .. 

Ran the upgrade like always but this time around all but one of the AP's updated .. So now I have one R310 that says "disconnected" and when I click on it there is a box that says it needs to be "upgrade" so i click on the box and select "online upgrade" as I have always done .. 

But it says the firmware version is up to date and will not upgrade this AP .. 

So not to sure on what to do .. 

Any advice ? and thanks for the help .. 

RUCKUS Team Member
Hi Josh,

What is the current firmware version?

If it is old, you might need to do a Local upgrade.

New Contributor III
Hi Josh,

Have you tried logging into the rkscli of that one AP and double checking the version by running the "get version" command and comparing it?

If the version is not the same you can download the appropriate firmware patch from the portal and apply a local upgrade either through the webGUI or rkscli.

Alternatively, you can factory reset the AP and let it rejoin the unleashed network again. As it would be factory reset it would technically be joining the unleashed network "for the first time" again and locate the master AP to get the same firmware and configs.

Community Admin
Community Admin
Hi Josh,

Please follow below.

1- SSH into the APs which are showing as disconnected or upgrade required.
2- Run the command "set factory" followed by "reboot".
3- Now without much delay, quickly delete the entry of this AP from Unleashed master AP GUI.
4- Wait for AP to boot up and wait for it to automatically join master AP. If it do not joins automatically, SSH into it with default credentials (super/sp-admin) and run command "set director ip" where x.x.x.x is master AP's IP address.

Follow this for all the APs which are showing disconnected or Upgrade required.

Another very important thing to check, make sure IP configuration on all the APs is configured correctly (correct subnet, correct gateway).

To review the IP configuration of AP from CLI, run below command.

get ipaddr wan

Syamantak Omer

Syamantak Omer
RUCKUS Networks, CommScope!
Follow me on LinkedIn

New Contributor II
Thanks Everyone for the help .. 

I did what Syamantak said and did the reset and rebooted it .. 

At first it came back up and said the same thing needs upgrade and then while i was on the phone with another customer .. it discounted so i waited and when it came back up it was updated .. 

strange , but i am glad is back and working .. 

Thanks for all the help everyone ..