Showing results for 
Search instead for 
Did you mean: 

Hi, do you have any idea about this error "bad firmware header magic" ? upgrading R510

New Contributor II

Esteemed Contributor II
Not enough info...  ZD or SZ managed, or standalone code?  What version to what version?  Does it work, or not?  Only one R510, or more than one?  Just R510 models?  Did it work before?

New Contributor II
R510 has fw 106 and ZD1200 has fw 9.9. i tried to convert the fw of R510 to 9.9 so it can be managed by ZD but during the upgrade error occurred "Bad firmware header magic". and AP can't be access thru CLI. I tried hard reset and download the fw again

New Contributor II
As per reading on the release notes of ZD1200 I discovered that R510 is not supported on the firmware version of Zonedirector 1200. That's why error occurred "Bad firmware header magic". Am I correct?.

New Contributor
I had a similar issue with some R500's:

See below, I sent the issue in with my ticket 00825708, the agent is RMA'ing both AP's:


-  Shipped AP on 104 firmware to property, AP gets "Failed to upgrade from 104 to 9.8.3"

- Ruckus support was contacted and made a decision that the AP had failed

-  Shipped a second AP that exhibits the same symptoms as the original AP.  I downgraded the firmware from 104 to 100, then attempted to upload the 9.8.3 firmware.

- AP is now giving a new error (bad firmware magic) and not connecting to the ZD.

- We had a T300 shipped as well with no issue.

- I also tried a local upgrade, the AP would take the firmware and do the whole reboot process, but when it came back online, it remained on standalone.