Showing results for 
Search instead for 
Did you mean: 

Can Not Update R610

New Contributor II

I have a R610, and I am trying to update the firmware. Normally this is very easy, just go to admin, the upgrade but it will not let me check the online or local buttons. I noticed it doesn't even show the firmware version.

I have tried resetting to factory and still same thing.

is there any other way to update the firmware?



I Tried Edge still didn't work. But apparently it must have been just to old of a Version. I got it to 200.09... and it is now letting me upgrade from browser. I had a R500 on the network also (took it off today) so the old version was 200.06... so that must have been the issue. I just wish it would have let me do a local update but it wouldn't let me do anything on the Browser only the mobile app.

Hi Darrell,

It must be browser compatibility issue with older version.

Let me know if everything is looking good now or you still have any issues.

Syamantak Omer | Sr.Staff TSE | CWNA | CCNA | RASZA | RICXI

New Contributor

I had the same exact problem. I then switched from Google Chrome to FireFox and it worked for me. I was then able to perform the upgrade.