Showing results for 
Search instead for 
Did you mean: 

Airplay dropouts on 802.11n

New Contributor III


I got an R610 with which does not give me any problems in general, except for one thing: airplay

I have tried almost everything, incl. for the AP to have 0% connections on 2.4GHz to force connections on 5GHz.

I stream from my iPad Pro which always connect with 802.11ac which is streaming to an Raspberry Pi 4B+ running RoPieeeXL (Airplay).

My problem is; when the Raspberry connects with 802.11n my iPad will loose the connection to the RPI within 20-30 seconds after I start streaming, when I then use the Troubleshooting (Unleashed) which can force the RPI to connect with 802.11ac the airplay connection will work for hours.

What I do understand is why does the connection get cut when the RPI connects with 802.11n and not with 802.11ac ?

Any recommended settings I should try out?

This is driving me crazy, as this is how I listen to radio ....


Community Admin
Community Admin

Hi @casper_pedersen,

MDNS is used for service discovery, so if you are not able to discovery devices when using Airplay then issue could be related to multicast to unicast conversion.

You can disable this from WLAN settings >> Advanced Options >> Directed multicast threshold >> Set it to '0'.

If service discovery is working fine and issue is with sharing the content, then it will need in-depth troubleshooting including OTA captures on AP and from clients when you face the issue.

As explained by eizens_putnins, it could be related to interference as well so try selecting good available channels as well.

If nothing is working and you are not able to fix it, open a support case.

Syamantak Omer
RUCKUS Networks, CommScope!
Follow me on LinkedIn

Hi @syamantak_omer, @eizens_putnins,

Thanks, it's not multicast (mdns) as the service is still seen - it's just drop outs on the audio stream.

But it's not the shairport-sync (airplay deamon) - when I steam from a wired computer (iTunes) everything is fine.

That makes me believe that it could be one of two things:

- communication between two devices connected to the same AP (doubt that).

- iOS / iPadOS having an problem (I'll play around with that over the weekend).

Thank you for your help so far.

New Contributor III

Hi @syamantak_omer, @eizens_putnins,

I found the problem, I had enabled Self Healing, Background Scanning, Client Load balancing and Radar Avoidance Pre-Scanning.

Switching these thing off solved the problem, Airplay is now working again without any problems.