Showing results for 
Search instead for 
Did you mean: 

ZoneDirector 1200 Firmware Upgrade

New Contributor II

Hi all,

I have a big project coming up next week to upgrade firmware of 2 x ZD1200 in Smart Redundancy mode, our current firmware is build 29.

Please could someone advise the upgrade path to the latest version, as I'm struggling to find our current build in newer versions.

We are going to be using a mix of R500 and R510 internal APs and T310 external APs.

Also, I tried to upgrade the firmware on the Active device last night but it just looked like it froze when trying to upload the .img firmware file, I was trying to use firmware version - maybe this was wrong which is why it didn't work? But I tried to search for the issue, and tried different browsers (Firefox, Edge, IE, Chrome) but they all did the same thing, gave no upload progress and did nothing for about 30-40 minutes.

Thanks for any advise!


@darrel_rhodes Hi Darrel, many thanks for the information!

I'll try doing a reboot of the devices and see if any different. We just purchased the new R510 to replace about 30 of our old APs as they were EoL and not supported on the newer firmware. Obviously, we left the R500s in place as they still are supported.

I have a backup of current setup already, just the issue of the .img file not being uploaded.


Hi Kuk,

please share the screenshot.

I've restarted both ZoneDirectors and trying the upload again but still seems to be stuck here, I'm trying to upload in Chrome.

Image_ images_messages_5fc8d020b6f95626499be125_8e46d12e07c1be4d559f362dfe23c745_Screenshot_1-ab44242f-303a-4ea2-833d-ae205b835a0f-882576555.jpg

The image I'm uploading you can see at the bottom.

Any ideas?


New Contributor III

Could you try an older vesion of firefox, i often use v.33 here:-

Worth a try.

New Contributor II

Okay, so I found a solution!

@paul_cremor thanks for the tip, however didn't want to start messing around with different browser versions just yet.

What I did to get it to work was to login to a server, to cut out my VPN connection and get onto the same subnet as the controllers, and also to put the firmware .img file locally onto the server to avoid UNC network path for the upload.

After doing this, it now gives me the prompt to backup and do the update!

Thanks all for help