cancel
Showing results for 
Search instead for 
Did you mean: 

ZeroIT redirect and Smart Redundancy

rob_coote
New Contributor III
In the Hotspot settings a redirect URL is set for unauthenticated clients to be sent for authentication. For us, this is the hostname of our primary ZD3000.

If Smart Redundancy is triggered however, and all AP's and clients fail over to the secondary ZD - with a different IP and hostname - the redirect fails (obviously).

Is there a way to ensure ZeroIT will still function properly if the primary ZD has failed?
17 REPLIES 17

ed_hynds
New Contributor II
Hi Rob,

Did you ever get this answered or figured out?

I'm performing the installation of a secondary ZD1100 for a client tomorrow and will obviously come across the same issue. They also use Microsoft NPS for 802.11 certificate based authentication so I would have thought I will need to take this in to consideration too.

I've looked on the forums and documentation and can't find anything that can help.

TIA

Ed

rob_coote
New Contributor III
Ed,

I haven't yet, although I suspect this may be part of the issue I'm having with firmware 9.7 and the redirection issue. The issue being it doesn't redirect. :)

I'd be interested in a white paper or "best practice" when it comes to setting up multiple ZD's as far as hostnames, IP addressing, SSL certificates, Management addressing, etc.

Rob

ed_hynds
New Contributor II
Rob,

Thanks for the quick response, I guess I'll have to see how I get on tomorrow!

By the sound of it I'll stay away from firmware 9.7!

Hopefully someone else (perhaps a Ruckus employee?!?!) could offer some advice on this post.

Ed

it_registration
Contributor
Hey guys here's what I did on my 1100's cause I had the same issue when I went live with 9.4.?

I configured Smart Redundancy

Then also under Configure>System I set "Management Interface" to enable IPv4 Management Interface. I set a static IP address for my network along with the rest of the configuration (netmask, gateway, vlan).

Then I made a static DNS entry on my DNS server to be zonedirector.domainname to the static IP address I entered for the management interface.

That way when a Smart Redundancy event occurs everything continues to work with a brief few minute outage while the standby ZD takes over.

For what it's worth I named my ZD's ZDPrimary & ZDSecondary. But all my name resolution is going to zonedirector.domainname.xxx.

Hope this helps.
Labels