cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade Zone Director 1000 Firmware 8.2.0.1 build 8 to 9.3.4.0.21 without premium support

johan_harianto
New Contributor II

Our company currently using Zone director 1000 with firmware version 8.2.0.1 build 8 with 25 AP Licenses build inside it and the premium support already ended a long time ago. It manages 20 Ruckus Zoneflex 7363.

The problem is the client sometimes still not connected to the nearest access point causing high ping and random timeout during the Video Call, and I found out about "bss-min rate" command, but it only available on 9.3.x


I already search and read all the release notes for each firmware and guide. 
So the plan in my mind is 
8.2.0.1 (current) => 9.1.2.0.8 => 9.3.4.0.15 => 9.3.4.0.21

My question is, is it possible to upgrade the firmware without the premium support?
Also, is there any risk the new firmware will brick the controller? If the controller bricked, is there a way to recover it?

14 REPLIES 14

eizens_putnins
Valued Contributor

Hi,

ZD1000 is very old. I am not sure if support enforcement works same way as for newer ZDs, but probably yes. So I suppose you will be capable to upgrade to latest version which doesn't require support to upgrade, I think 9.3.4 must be ok. But you need images anyway.

About upgrade risks.

1. Never upgrade ZD in smart redundancy mode. Make they  standalone and upgrade separately.

2. There is always some risk, same as with firmware upgrade for MB. But do it correct way, and usually it works. Most important -- don't lose power in the process.

3. There is recovery proceeding (to upload new firmware image to bricked by upgrade ZD), which usually helps.

4. In the worst case you probably can get very cheap replacement ZD1000 or Zd1100 from Ebay.

@eizens_putnins 

We only have one zonedirector, to be safer  since we only have one zonedirector. I plan to upgrade it with stand-alone , just the zonedirector connected to my laptop.

My question is the Access Points 7363 need to be connected after each step upgrade path?

mitchell_axtell
Contributor II

As 9.3.4.0.21 was a security fix at some point it was offered for free, but it may not be the case now.  May be worth asking.

As for hops, the current -> 8.2.2.0.7 -> 9.1.2.0.8 -> 9.3.4.0.21 should work.  The release notes for 9.1.2 show the below:

ZoneDirector cannot be directly upgraded to 9.1 from 8.2.1, 8.2.0, 8.1 or earlier versions (ID
16432).
Workaround: upgrade to 8.2.2 or 9.0 before upgrading to 9.1

@mitchell_axtell thank you very much, I will check it for the steps on the release notes.

Labels