cancel
Showing results for 
Search instead for 
Did you mean: 

Can vlan 1 be explicitly tagged on a WLAN?

joshua_rusch
New Contributor II
Hi,

When my network was initially set, our internal network was set up on VLAN 1. The ruckus was configured on VLAN 10 (no management interface). I now want to set up a WLAN directly on VLAN 1 so I can use the DHCP server there and my wireless clients can be on the same subnet. Now, on 9.1.2.0.8, I wasn't even allowed to set the VLAN field to 1. Yesterday I upgraded to 9.6.0.0.267. I can now set a 1 there, but it seems to be the default and I still seem to be on VLAN 10 as that is where the DHCP server that is giving me an IP address resides.

Other Configuration info:
1) Ruckus Zone Director is on VLAN 10. No management interface is configured.
2) DHCP server is disabled, I've been using independent DHCP servers on each VLAN
3) Switch config for access points are untagged VLAN 10 and tagged everything else
4) Switch config for zone director is tagged everything, although I have tried untagged for VLAN 1.

As I've had no issues setting up WLANs on other VLANs, I'm wondering if there's something special about VLAN 1? Should my internal network not be there? Did I miss something in the user guide? Is there some other setting in the Ruckus somewhere I need to change? Did I just make a boneheaded error several times?

I think my next step is to see if I can do this via dynamic VLANs as I do intend to use RADIUS there anyway.
14 REPLIES 14

joshua_rusch
New Contributor II
OK, I got the same results with dynamic VLAN. I think perhaps I may be a little confused about how the untagged setting works on the switch so I'm doing a little reading on 802.1Q. But even considering that, I'm still confused as to how I'm getting the DHCP server that is explicitly on VLAN 10. More reading, LOL.

santosh_bittu
New Contributor III
Hello Joshua,

with reference to your post, I understand the following:
-- The ZD and AP are on VLAN 10 and you would like to have a WLAN tagged with VLAN 1.
-- Although the WLAN was tagged with VLAN 1 they still get an IP address from VLAN 10.
-- ZD is on VLAN 10 and AP's are connected to ports where VLAN 10 is untagged.

Kindly correct me if I am wrong.

The issue here is when you connect you ZD and AP's to access ports on the switch where VLAN 10 is untagged, our devices still consider themselves to be on VLAN 1, since by default the Ruckus devices are on VLAN 1. Hence when packets hit the switch port they are passed anyways through VLAN 10 and will be able to reach the devices.
Also since the AP's are connected to ports where the VLAN which is untagged is VLAN 10, hence all clients will automatically get the IP address from VLAN 10 since this is the native VLAN on this port.

To resolve this issue you need to follow the below procedure:
-- First you need to place the devices on management VLANof 10 (ZD and AP), when any information with respect to VLAN is entered on the ZD , it means that the devices understand only tagged information.
-- Now on the ZD you will need to change the AP's VLAN, this can be done under Configure > AP > AP Policies > VLAN > Tag 10 here, the moment you hit Apply all the AP's will disconnect.
-- Now under Configure > System > IP Setting > VLAN > Tag VLAN 10 > Hit Apply. The ZD will restart for the changes to take effect.
-- We will then have to change the port configurations, the ZD needs to be connected to a trunk port allowing the Native VLAn along with VLAN 10 as tagged. Similar configuration needs to be done for the AP's.
-- Once this is done all the AP's and ZD will be managed on VLAN 10 and this is a tagged VLAN.

Now you can tag the WLAN with VLAN 1 and this will allow your clients to receive an IP address from the appropriate DHCP server/scope.

Kindly let me know if you have any questions. If you need further assistance is setting this up, kindly contact support and we will be able to help you set this up.

Hope this helps.,All the best.

joshua_rusch
New Contributor II
Thanks so much for your help! Will try to work through your instructions right now.

But at a glace, I do have some questions (maybe they will answer themselves when I try this out)

I'm using HP switches, and I think the term trunk is used differently here. I think you're using it in the cisco sense? I just need to set all my VLANs to tagged on this port to make it a trunk, right? Nothing untagged?

The zone director has always had VLAN 10 in it's IP configuration. It's just the APs that are on untagged VLAN 10 ports. This is the way it was set up for me.

I also found the "untag ID" in access point groups that I can set by model. I was unclear what it means in this context. Whenever I changed it from anything other than 1 (I tried 10), the access points could not talk to the ZD, it didn't matter. Even if I don't need this setting, it would be great if you could explain that one a little better for me than the user guide :)

Anyway, off to follow your instructions as best I can 🙂 Thanks again.

PS, I have a ZD1100, forgot to mention that, not sure if it matters.

santosh_bittu
New Contributor III
Joshua,

Can we have a discussion before you try this , the reason being I dont want to miss out on any steps and can better understand how your network is actually setup. Can i have your contact number for me to give you a call.
Labels