Showing results for 
Search instead for 
Did you mean: 

Discussion around issues in Catlina MacOS

Esteemed Contributor II
There has been a lot of chaos on Catalina MacOS and its interaction with networks that have deployed Ruckus products for wireless service.  Issues are being seen in current Catalina MacOS that did not appear in earlier releases of MacOS: Mojave, High-Sierra, etc.

TAC managers have asked that we share information with our customers.

It is recommended that Macbook users use 10.15.4 who wish to use Catalina OS or have got an relatively older version of Catalina MacOS: namely 10.15, 10.15.1, 10.15.2 or 10.15.3. Apple has fixed a variety of bugs including but not limited to Wi-Fi, Safari stop responding when attempting to use Apple Pay, HSTS enhancement etc.

Apple has released beta version of 10.15.5 and it will soon be available officially on their website.

Some of the useful URLs on issues encountered with Catalino OS are:






Please note that Catalina is true 64-bit operating system and Apple has asked all the users to use 64-bit version of those applications. Please read the following URLs for further information:



Quotes on 32-bit applications:

“Apple first announced that it would ultimately wind down support for 32-bit apps more than a year and a half ago, when it began pushing alerts to macOS High Sierra users that 32-bit software was “unsupported.” The apps still worked, but with Catalina’s official unveiling back in June at WWDC, Apple made the eventual discontinuation official. With the launch of Catalina, 32-bit apps no longer function.”

Just to round out this thought process… I have had the Ruckus TAC close the case looking into this issue as I have not been able to reproduce the fault with any of the three 2015 Macs that I've been testing with.

These have been running 10.15.4 and 10.15.5.

Since upgrading the Ruckus AP's to firmware version the issue has not manifested at all.

While it's not the same as actually getting an answer… with neither my test machines nor the fleet of 700+ student owned devices having this problem any more… I'm calling it solved and I'm as confident as I can be that it's the Ruckus AP firmware update that fixed it.

So is there no fix for non smart zone applications? 

Hey Mark,

I can't comment on a fix for unleashed AP's, because I'm not in a position to test, but Ruckus released Unleashed AP version on 27th Oct… which is newer than the SZ firmware I'm running.

So maybe try it and see?

Really kind of bummed Ruckus a) didn't do the legwork to confirm this in the lab b) was not able to confirm to you (and others) that there is actually a confirmed, tested fix.

Someone else mentioned ChannelFly and background scanning - we had both disabled while seeing the problem.

I was just curious if they would have acknowledged across the board other than just try it and see if it is corrected.

We have updated a few with mixed results. I can not say for sure about the client's OS being updated or not