Showing results for 
Search instead for 
Did you mean: 

Setting ethernet port mode to bridge in Unleashed (R500)

New Contributor
The R500 has two ethernet ports. It seems however there isn't the level of detail or configuration i'd expect with the physical ports compared to the flexibility of other options in Unleashed.

I checked the command line but the only reference is in the ethernet port status:

ruckus# show ethinfo

System Ethernet Overview:

  Port  0:

    Interface= eth0

    MAC Address= d4:00:00:00:00:00

   Physical Link= up

    Speed= 1000Mbps

  Port  1:

    Interface= eth1

    MAC Address= d4:00:00:00:00:01

    Physical Link= down

    Speed= 1000Mbps

What i want to do is be able to bridge the second port in, so another device can connect to the network. So fairly simple. Note i have not connected the device yet. How do i set this?

However as an aside, i would have thought i could also configure the vlan options of each port, whether it is trunk/access mode, etc. Am i missing something?


Hi eXDeeNZ,

We can have a client connect to second port and use it, it does not need any configuration, unless you want it to get an IP from different vlan.

Abilash PR.

And how can we configure it to a different vlan?

you can get this to work (tested on unleashed on a r610 , latest unlsh version as of may 2022),  but i cant confirm that it will be saved / persist across reboots (but it *should*).  Unfortunately, as usual, Ruckus standalone firmware has the most features,  so lets jump back to standalone FW syntax to get this to work on unleashed:

1st-  SSH into the AP you want to change its 2nd ETH port's untagged vlan to.   (you have to do this on each and every AP you wish to change)

(if its the unleashed master after SSH prompt, you will 1st have to do,  enable   then ap-mode)

then run:   get eth    (to confirm you are about to switch the CORRECT ETH PORT,  as if you change the wrong eth port you can loose your connection to the AP and possibly be locked out fully) -  as a general rule:  be sure you are not changing the eth port that has POE marked on it (as this is MOST LIKELY the "uplink" port your ssh session is running over).

then run:

set interface eth1 type access untag 702         

(where 702 is the VLAN you want as untagged on that 2nd eth port). 

to see other options (like setting it back to a vlan trunk port),  issue command:  set interface (press return to see the help,  or i think set interface ?   will give you the help as well).  the help screen is very good on ruckus CLI btw!.

also this feature should 100% be added to unleashed web GUI ASAP.  if you see this link below (back from 2020!!  this functionality is only available on 2x unleashed AP models, which is absurd).   This inability to change (or even DISABLE) the 2nd eth port of unleashed APs actually can be a pretty big SECURITY issue in most environments / configurations.

(its GREAT that ruckus gives us so much functionality on the Standalone Firmware, but much of that still needs to be brought over to Unleashed.  While it does have its bugs, Unleashed really is a GREAT platform)

For whoever ends up here looking for a solution, having tested this with latest unleashed (v200. on R550, the setting is not persistent, meaning it doesn't survive a reboot.

That is, unless I'm missing an additional command, that isn't listed above, and is supposed to make the setting persistent.