Showing results for 
Search instead for 
Did you mean: 

R650 Poor Performance / Throttling

New Contributor

I've been seeing very poor throughput out of the box on my R650. I never seem to get more than 200Mbps on the 5Ghz network. I've tried every combination of settings that I can think of, but it doesn't change anything. I have the 5Ghz network on its own SSID, Wifi6 button selected, utilizing auto channels and channelization. I have 4 specific channels setup in the upper 5Ghz range, but with my phone using the SpeedFlex app and testing two different Windows machines with Intel 210AX cards in them, all throughput numbers are exactly the same (~230Mbps). Drivers are all up to date. I'm on the latest Unleashed firmware Really at a loss what to do now.


New Contributor III

I've fixed my Ruckus 650 poor performance issue, instead of doing POE I plugged in an AC adapter and now my phone gets 900Mbps instead of 500Mbps. I don't understand why that's the case when I wasn't getting any power warnings and I even tried manually setting the AP to 802.3at. 

View solution in original post


I ended up having some kind of throughput problem with the switch it was plugged into. Not related to power. It was weird because weird transfers through the same switch were fine, but via wireless it was throttled to 200mpbs. Plugging into a different switch resolved the issue.

Same here. Ended up being some managed switch traffic options. 


Hi Nick,

R650 needs PoE+ : 21.59W (peak) power to provide it's maximum performance.

Post changing the power mode manually did you check the power status and power allocation on switch side?

Syamantak Omer | Community moderator | Staff TSE | CWNA | CCNA | RASZA | RICXI | Follow me at

New Contributor III

Yes and the switch would sit around ~16-19W of actual consumption however that did not fix the throttling.  Only solution that I've found was to plug in to AC.

New Contributor II

Unless using a switch that speaks Ruckus power negotiation methods, you may have to manually specify override the power settings in the AP or Manager. The UI should alert you that it is using low power though. If all of this is done with a factory reset and updated firmware, then I would assume hardware fault somewhere.