cancel
Showing results for 
Search instead for 
Did you mean: 

NEW R510 not accessable through browser or configure.me | My story and how i solved it

M-Maculata
New Contributor II

Hello. Just wanted to share the solution to my problem with connecting my newly bought R510, as I read every single post I could find on the R510 and it was only after reading all of them that I was able to put the dots together. None of them were complete. I am not an IT person, but I generally figure out whatever I set my mind into and I do generally know how computers and networks work, more or less. It took me a whole afternoon, like 8 hours, to set up my Ruckus R510. I am sure a professional would have done it a lot quicker, but the professionals dont consider the basics because they take it for granted that you know these things. So if you are not a professional, you should read this. And if you are a professional, you might also want to take a look so you can update your guides.

My setup:

I have a normal router from my ISP that gives me internet. Its crap, like what do you expect, but you gotta have it. So I disconnect the WIFI on that one and just tunnel the traffic through the ethernet to a normal 8 port switch, where one of the ports is going to another router with more powerful WIFI somewhere else in my house. I have ethernet outputs in every room. My house is about 120 square meters, all on one floor and has several concrete walls. I needed a new router, a more powerful one.

My story:

So I landed on a Ruckus R510. I was new to this world of "professional" routers, but was intrigued by the possibility to have airport quality wifi in my home, and started my journey. So i read up on the subject and figured that even if these routers are supposed to be linked together to provide better coverage, you CAN buy one single unit and run your wifi on it. So i purchase a R510 and our journey starts here.

Journey:

So I receive the R510. I ordered it to be delievered the next day. Paid like 20 euros extra for that. Only to open a box that has no A/C adapter in it. Thats right. Rookie mistake #1. They are purchased separately. Why? Because generally people who buy these things connects them with PoE (Power over Ethernet) That was also my intention, but firstly I wanted to get it up and running before buying more items. Now you are thinking, if you are a rookie, that maybe you can use just any a/c adapter. No you can not, because although the Voltage is the same, the input/output is different so you might end up damaging your equipment. Unless you find one with the exact same input/output as the original adapter. I have like 20 in my house and none matched, so dont waste your time and go buy what you need. And if you have connected a random a/c adapter, now is the time to go unplug it.

You do not need an expensive switch. Not too obvious if you are not an expert but after reading up on it i bought this: https://www.tiendacables.com/16914-ubiquiti-networks-u-poe-af-8023af-supported-poe-injector-u-poe-af...

So i receive my injector and i take the ethernet cable that goes to me switch and plug it into my injector. I am not sure if it really matters, but I wanted to plug it straight into the source and dont get into conflicts.

I fire it up and download the unleased app on my phone. A configure.me wifi appears and i try to connect. This is where the problems start. It requires a password. The password turns out to the the serial number on the back. Moving on. Once accessed the wifi it does not assign an IP and therefore it does not connect to it and I can not start the unleashed configuration. After resetting the router several times, nothing helps so I connect a laptop directly to the router and try to access the default address 192.168.0.1, after configuring my local network with the IP 192.168.0.22 and subnet mask 255.255.255.0, like specified in the manual. Does not work, also i can not ping the router. I disconnect the R510 from the net. Same result. I then reconnect the R510 and login to my ISP router on 192.168.1.1 to check if is connected to my R510. I find that the R510 has been assigned the IP 192.168.1.142, which means it does receive a signal. I then change my ethernet on my computer to automatic and get internet access through cable. Internet passes through the R510 but I can still not connect to it. I proceed reading every single post I can find on the subject, and its only after reading a million articles and re-trying every step a dozen times, that I discover that there is a difference between UNLEASHED and a normal AP (accesspoint). This was not easy to find information. Obvious information for sure, but starting from 0, it´s not too easy to find out.

If you have purchased an UNLEASHED r510, you have a 9U1-R510-WW00 whilst if you have a normal AP, its a 901-R510-WW00. This means that obviously you can not configure it as unleashed. But do not despair, because after some more reading, I understood you can change the firmware on your normal AP to become an UNLEASHED unit. In my opinion, this should be the first think a technicion asks a client about. This also might apply to you if you DO HAVE an UNLEASHED, but someone has changed the firmware to normal AP. The product code is irrelevant, what is relevant is the firmware. If the unit is new, like mine, obviously it has the original, but I have read a couple of threads where I suspect people had units where the firmware was changed, so pay attention to this.

So how do you change the firmware if you can not access it? Google guides you.

1) You need to login to the router with SSH. I downloaded the Bitvise SSH client.
https://www.bitvise.com/ssh-client-download

2) Download a TFTP server that will be used to send the new firmware to your router. I downloaded the TFTPd32 server: https://www.netadmintools.com/tftp-servers/tftpd32/
Select your computer as the server under the "server interface". In my case it was 192.168.1.147

3) Download the correct firmware and save it in the same folder as your TFTP server.
https://support.ruckuswireless.com/software/3323-ruckus-unleashed-ap-200-12-10-5-234-ga-software-for...

4) Open the cmd window in your SSH client and you will be asked again to log in with default user/pass. Once in you need to find the right commands. You will find threads on this, but the commands they tell you to use wont really help you as they dont tell you the first steps on how to get there. First you need to write "help" to see the commands. One of the options will give you access to advances configurations. Once in, if you write help again you will me swarmed with the different commands you can use. You want to enter ap-mode. Once inside the ap-mode you can start configuring and using the commands you find in different threads about this subject, but they are pretty straight forward. Just write help and you dont get that many options. You now need to define the TFTP IP you want to use. How do you know the IP? Its the same one as you selected in your TFTP server. You need to use the commands to tell the R510 that it will find what it is looking for on an TFTP server on PORT 69, on which IP Address, and the NAME OF THE FILE (that you have saved into your TFTP server folder) Only when all of these options are correct you are ready to update.

When you run the update command, you can see the progress in your TFTP server and you will receive a message once it has been completed. Before shutting it down, use the show command to check if it has been updated correctly. Your router has 2 images stored and i will tell you which one it is running. In my case the image 1 was left blank and now it was running on image 2. Something was no correct. I factory reset my router but it remained the same. I repeated the process and now it was updated correctly and was showing both image 1 and 2 with firmware, using the show command. I was still not able to access the configure.me network so i did a factory reset again and confirmed with the show command that both images were still correctly. And now it worked. I connected to the configure.me wifi and everything works smoothly.

Yes, I am an amateur, and I know that the consequences could have been ruining something, but the way I saw it was that I already had an expensive router that was of no use to me unless I could convert it to an unleashed router so I took it as a challenge and I learned something on the way. Worst case I would just buy a new one. I just hope that this post can make it easier for people in my situation to solve their problem, because not all of us are IT experts.

 

0 REPLIES 0