cancel
Showing results for 
Search instead for 
Did you mean: 

Forcing a client to connect to specific AP under Unleashed + Mesh

andrew_se
New Contributor

We've got R510 + R310 APs, all connected into one Unleashed (200.7) network, with Mesh enabled.

Few clients seem to have issues connecting to nearest AP (R310), which causes slow network access and interruptions. When they re-connect to unwanted AP (R510), we can either reboot that AP (R510) or reboot the client, and it will get back to nearest AP (R310). But it doesn't stick and we have to repeat this, which is not optimal.

I've seen some very old discussions which were not helpful, including stuff about AP groups and WLAN groups. I don't see such options in the interface, possibly because Mesh is enabled.

I imagine one of the following might help:

- Forcing certain AP to broadcast certain SSID.

- Prevent certain AP from broadcasting certain SSID.

But so far I'm not seeing any possibilities to achieve any of that.

10 REPLIES 10

eizens_putnins
Valued Contributor

You actually need check a few things:

1. Check if you have possibility to configure roaming settings on client device.

2. Check that you have 802.11r and 802.11k disabled, and 802.11d enabled on the network. If something is different. correct and test again.

In the worst case you'll need to redesign a network or replace affected clients - there are some devices, which are unconfigurable and doesn't work normally in any environment which had more than 1 AP with the same SSID (such as some Psion PDA models (with completely broken roaming) and some card payment terminals).

The device is TP-LINK TL-MR3020 in bridge mode. I didn't find any setting that would help. I don't think there are "roaming settings" there at all. But the actual client connected to it is stationary. There are 2 more stationary clients (same device model in bridge mode) located nearby (2-3m apart) and they don't have such a problem.

We already have 802.11r and 802.11k disabled, and 802.11d enabled.

syamantakomer
Moderator
Moderator

Hi Andrew,

You can increase the BSS min rate which will force client to connect to it's nearest APs till some extent.

Another way is smart roam but that is only support on CLI.

Last option is creating a separate SSID and map it to specific AP(s).

Refer below KBA for smart roam and BSS minrate.

Smart roam: https://support.ruckuswireless.com/articles/000002277

BSS min rate: https://support.ruckuswireless.com/articles/000002692 

Regards,
Syamantak Omer
Official Rep | Staff TSE | CWNA | CCNA | RASZA | RICXI

Hello.

Before trying any settings that might affect all network I'd like to evaluate other options. You mentioned the option to create a separate SSID and map it to specific APs. How can this be done? I didn't find anything like that in the interface when creating a new SSID.

Also, the BSS min rate link you gave returns an error.