cancel
Showing results for 
Search instead for 
Did you mean: 

Can you correct incorrect/invalid boarddata with a completely different model?

radiosilence
New Contributor

I have an R610 access point that will ends up in a reboot loop (its NOT an R710, as it thinks..) the moment that its given configuration (or so I suspect).

The odd bits are that the device seems to have written, at some point, that its an R710 instead of the R610 that it is.

At login, the "motd" shows the following message with a completely zero'd serial number:

Please login: super
password : 
Copyright(C) 2021 Ruckus Wireless, Inc. All Rights Reserved.

** Ruckus R710 Unleashed AP: 000000000000

This ap is running the absolute latest version of 200.10 - 200.10.10.5.246:

rkscli: get version 
Ruckus R710 Multimedia Hotzone Wireless AP
Version: 200.10.10.5.246
OK

The boarddata seems.. very wrong:

rkscli: get boarddata
name:     R710
magic:    35333131
cksum:    c8f
rev:      5.4
Serial#:  000000000000
Customer ID: 4bss
Model:    R710
V54 Board Type: GD50
V54 Board Class: QCA_ARM
Random#:  0000 0000 0000 0000 0000 0000 0000 0000
symimgs:  yes
ethport:  2
V54 MAC Address Pool:  yes, size 16, base 6C:AA:B3:3D:59:10
major:    258
minor:    1
pciId:    0000
wlan0:    yes 6C:AA:B3:3D:59:18
wlan1:    yes 6C:AA:B3:3D:59:1C
eth0:     yes 6C:AA:B3:3D:59:13
eth1:     yes 6C:AA:B3:3D:59:14
eth2:      -  6C:AA:B3:3D:59:15
eth3:      -  6C:AA:B3:3D:59:16
eth4:      -  6C:AA:B3:3D:59:17
eth5:      -  00:00:00:00:00:00
uart0:    yes
sysled:   no, gpio 0
sysled2:  no, gpio 0
sysled3:  no, gpio 0
sysled4:  no, gpio 0
Fixed Ctry Code:  no
Antenna Info:  yes, value 0x00000000
usb installed:  no
Local Bus:  disabled
factory:  yes, gpio 8
serclk:   internal
cpufreq:  calculated 0 Hz
sysfreq:  calculated 0 Hz
memcap:   disabled
watchdg:  enabled
FIPS SKU:    no
FIPS MODE:   disabled
OK

I can't find a way to correct this. There's little to no difference in the command outputs I've seen from both the userspace commands (using uart to access the console) nor in the u-boot bootloader environment.

In the kernel messages during boot, there seems to be an issue with the system retrieving the required data:

[    0.084163] read_version: Error in QFPROM read (-95, 0)                                       
[    0.084175]                                                                                   
[    0.084175]  Version Read Failed with error -95pinctrl_dt_to_map: Choosing R610/R710 pinmux

Is there any hope to fix the data read in by the system? If it was able to be inadvertently corrupted..could I "corrupt" it back? Does this speak to malfunctioning hardware?

2 REPLIES 2

syamantakomer
Moderator
Moderator

Hi there,

If this was purchased by an authorized Ruckus reseller, please contact them or directly open a support case with Ruckus support.

They can access the AP and correct the serial number, but only after verifying the authenticity of device and its owner. If you have more than 1 AP in such condition, all such APs will be replaced.

Regards,
Syamantak Omer
Official Rep | Staff TSE | CWNA | CCNA | RASZA | RICXI

chris_hayden
New Contributor

How strange, I have the exact same problem with a r510 I purchased. The boarddata it reverts back to is that of an r710.