Showing results for 
Search instead for 
Did you mean: 

Unit will not power on

New Contributor

Similar to other posts, I get a flash when plugged in, then nothing. I have tried other cables as suggested in other posts, but the unit is unresponsive. Looks like a replacement situation. 


RUCKUS Team Member

Hi @Jj1271 
Could you please confirm if this is a Lennar home setup?
If yes, I can redirect this to our dedicated Lennar support for further assistance.

New Contributor

Yes, it is a Lennar home setup. Thanks!

RUCKUS Team Member

Thank you for the confirmation, let me involve our dedicated tech support for Lennar homes.

Hi @Jj1271 


Thank you for contacting RUCKUS Lennar Home Community.

Hope you are doing well!!!

Thank you for the information you shared.

As per the case description, I could understand that your RUCKUS setup is not working, and the unit is not powering up.

Could you please let us know the answers to the below queries to assist you better?

1. Was this working before or is it a new installation? If it worked before, was there any power outage before you started facing this issue?

2. On your switch while it's plugged into the outlet, do you see any lights on? (Amber or green) Please let us know which lights are on. (Please refer to the below picture and share a picture of the same)

3. May I know how many Access Points are connected to the Switch? Could you please let me know the light status on the Access Points? Any of these lights are on (Please refer to the below picture and share a picture of the same)

Please help us with pictures of your ICX-7150-C12P Switch showing the status of the lights. Also, light the status of Access Points.

Before uploading the photos please log in to the RUCKUS account and you can upload the image.

Please let us know the answers to the above queries or if you have any queries in this regard.

Thank you again for your patience and understanding.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.