Showing results for 
Search instead for 
Did you mean: 

Slow Download Speeds R710 Unleashed

New Contributor
Strange issue with R710 on latest unleashed firmware. Upload speeds consistently incredible on both laptop and phone but downloads even from 5 ft away never go over 200 but stay consistent through 3 thick walls. Speedflex on android shows 550 up 550 down to AP. Iperf reflects results. Cable shouldn't be the problem as I have plugged my laptop on it and gotten the gigabit fiber speeds I should be getting. I have factory reset it countless times set everything to auto and tried manually setting the bands and channel width, am I missing something? Any help would be appreciated.Image_ images_messages_5f91c3fe135b77e24790df97_43e5db9b2eca36b81d35b46dbdb8f876_RackMultipart20190818868831y92-dc568500-96c2-4610-9714-84fb1bdd684c-743324385.jpg1566155318
379 REPLIES 379

Still why doesn’t support iperf3?

Anyway I replied to the support and asked them please clarify what they mean.

This is their reply

There is an issue with speed test tools including online iperf and speed test on unleashed newer versions.

Engineering team is working on these inputs internally however they did the testing and there is no much difference in throughput results of 200.4 to 200.8.

Please confirm if we have any performance issues on the client network.

Right now things are just still inclusive and further testing is still being done.

There seems to be confusion on everyones part back and forth. Here is my notes after testing thoroughly, same network, same ISP same set of AP's;


200.7 - Had the iPerf3, Ookla and Unifi Speedtests significantly Better. All average around 400-500mbps up/down. Speedflex barely works and when it does the throughput shows 100mbps (+/-20) which I am certain is inaccurate.

200.6 - Had the iPerf3, Ookla and Unifi Speedtests somewhat worse than 200.7. All average around 300-400mbps up/down. Speedflex actually worked better and the throughput was around 150mbps (+/-20)

200.5 - Had the iPerf3, Ookla and Unifi Speedtests way worse than 200.6. All average around 200-300mbps up/down. Speedflex actually worked best and the throughput was around 300mbps (+/-20) which seems 200.5 Speedflex still worked.


200.8 - Had the iPerf3, Ookla and Unifi Speedtests at worst results. All average around 80-100mbps down and around 30-40mbps up, huge cut on up speed for some reason. Could not get speedflex to work.

200.7 - Had the iPerf3, Ookla and Unifi Speedtests a bit better than 200.8. All average around 200-300mbps up/down. Could not get speedflex to work.

200.6 - Had the iPerf3, Ookla and Unifi Speedtests at it's best. All average around 500-700mbps up/down. Speedflex actually worked and the throughput was around 300mbps down and 600 up (+/-20)

200.5 - Did not test, this FW kills the SECOND LAN port which I needed to use so I did not bother testing. I presume should be same or slightly better than 200.6

I think SpeedFlex is not a good tool. Maybe it's good to check AP to AP speeds. Because every time I tried AP to AP speedflex, always get a 1.3Gbps up/down between ap's. Client side testing does not stay within range of other tests mentioned above.

Also, whoever said enabling mesh, and/or arp filtering helped, it did not. I extensively tested and reset a bunch of times, if anything, arp filtering made it slower. Enabled mesh did absolutely nothing on my bench units.

So 200.6 came out in 8-7-2018 .. I wonder if all products after this release date has been hosed. It does seem like since going to vSZ 5.0+ that things in our environment suck majorly. Before that, we were at 3.6.1 .. (3.6.2 was released around 9-14-2018 so that might be fine as well).

Sorry if this was already answered, I didn't see it.  Is there a rough mapping of "good' ZoneDirector versions?


standalone 200.4 == ZD ???

standalone 200.5 == ZD ???

standalone 200.6 == ZD ???