Showing results for 
Search instead for 
Did you mean: 

Ruckus keeps dropping connection

New Contributor

Hello, recently moved into a Lennar new construction home and ruckus unleashed along with two APs R510 are included with the home. 

Amazon Services helped setup connection and everything seemed to be working initially. However, within a day, I stopped having access to the internet. I get internet access back after unplugging ruckus from router and restarting router then plug everything back in. It will be fine for a bit for some hours then access is dropped again. 

The internet access issue does not occur when I stopped connecting router to ruckus and only use internet standalone between modem and router?

Any ideas why this is happening?



Have you tried to disable the Wifi on your router.  The APs supposed to be your SSID thorough the house. More than likely, you have SSIDs clashing between your wireless router, modem and the APs.  Disable all wireless, and only use the ones from your APs.  That's the way Lennar and Amazon Smart home has it setup.  i live in newer developed Lennar community too.  So, this is a common issue with new tenants.


Yes, I have tried both ways. Same result with dropping wifi. 

Who is your ISP? Do you have your own Modem? with AT&T and Comcast, you just use their routers and the Ruckus APs.  Disable the Wifi on the Router.  If you have these 2 ISPs, i would remove your personal modem, it just complicated the network topology. Ruckus is not very solid as you will soon learn..., you don't want to confuse their firmware.  When it is running, you learn to leave it alone, and don't try anything fancy:-)  Also, check your AP's firmware. last good one is 200.8.  Do not upgrade from their if you appreciate your up-time...

I have internet through Spectrum only. The modem is provided by Spectrum. The router is mine. I have the same experience with wifi dropping when I disabled or enabled the wifi signal on the router. 

Amazon tech who walked me through the setup had me upgraded to 200.9 so how do I get back to 200.8?  I’m not technically advanced so plz provide good explanation. 😉