Showing results for 
Search instead for 
Did you mean: 

Ruckus R720/R710/R610 Unleashed half speed download

New Contributor II
Dear Ruckus, I have invested enough money to get fast and seamless internet on my APs. Not only did I recommend Ruckus Unleashed to many of my friends who wanted a fast and stable internet connection, and they also bought your points. But it is not, stable - yes, seamless - rather yes, fast - no. I carefully read all the similar problems in this forum over the past and did not find a single solution to the problem with half speed internet. Some offer a downgrade to 200.4, some Standalone. But this does not solve the problems if you have a few modern points with Wave 2 (which have the earliest firmware 200.5) and there are not so many to buy ZD. But what is more frustrating is that all the solutions are offered by users, not Ruckus himself. Even the timing of its decision is not defined. Recently a new firmware 200.8 was released, but this problem is still not solved. Because it’s really a problem when an AP for $40 gives Internet download speed up two to three times faster than at a point for $1500. Just tell us you are solving this problem or not? And when is the result possible? If it drags on for a long time, it’s easier to sell all my APs on eBay and switch to another vendor.

Related posts:

Thanks. Is that on non iOS devices?

Also, those rumors came out very close to each other. What is the difference?

New Contributor III is broken:

-Download speeds arbitrarily capped at ~250mbps or abiut 1/2 to 2/3 upload, where a Comcast all in one gets between 300-400. Channel and width changes do not help. 106 firmware does not help.

-Lag is experienced by my tenants with game consoles and they send me text messages at 2:30 in the morning, livid because this happened last time I tried to get the download speeds fixed with any firmware but the early 106 one.

-iPhones significantly faster on ISP router when we had their internet.

Looking at another enterprise competitor, this seems to be a common thing: destroying single client throughput and making gaming a terrible experience at all costs. The excuse of "it's optimized for many users and businesses uses like video calls and QoS to make sure people can stream and browse smoothly" is terrible, as we have had 25+ people within 30 feet of the prior router and the ISP one is fine.

I have no credibility with tenants now who love to bring up the internet problems every time they pay rent, and one has threatened to not pay until I get a new access point.

This was an expensive mistake, and I was willing to pay out the nose for an access point to not cause this headache.

Going forward I highly recommend engineering tests using on a gigabit connection to ensure access points work for home/rental/small business use with default unleashed settings.

Also worth it to have an intern take one home and play first person shooters for a week to see if there is real world lag, or to click around on a YouTube video and see if it has to buffer at all. An excellent modern router should not even show the loading circle.

I apologize to those working diligently on this and trying their best, but I am not able to reconfigure or otherwise change from 106 firmware to perform further tests as it causes too much friction with tenants and I don't have a console to test with.

Hopefully I can squeeze a new system in at 4AM and avoid them being passive aggressive for weeks.

New Contributor II

I just bought an r710 in an attempt to get a faster and more solid connection than the Ubiquiti AP I was previously connected to and, despite being closer (~3' away, on the other side of a wall, versus ~25' through ~5 walls, it's no better, and possibly worse, and the overall reach is worse than the Ubiquiti. I was excited about it based on stuff I read with people raving about Ruckus, but it's been a massive disappointment and waste of money. The absolute best speed I've been able to achieve is just under 480Mbps, and with what should be a proper/normal setup, it's between 10 and 80. I've tried multiple firmware versions (6, 8, and 10) and have tested the speed with an online speed test, SpeedFlex, and copying a file over the network.

The only thing I've found that helps is limiting it to 5GHz only, which is what allows me to get 400-480Mbps, otherwise it always uses 2.4GHz and moves extremely slow. But those speeds I'm getting on 5GHz are much, much slower than they should be, and even slower than I should get on 2.4GHz. It just doesn't make any sense, and the only conclusion I can draw at this point is that Ruckus APs are just complete junk. I wish that wasn't the case, because I was really hoping to have found a new and great one that I could use as well as recommend to others, but clearly this isn't it.

There's almost no other 5GHz traffic here, and only a small handful of 2.4GHz networks, most of which are relatively weak, so it's no an interference issue, not to mention one of the big things with Ruckus is its supposed ability to handle that with ChannelFly. If anybody has any suggestions, I'd love to hear it.

@s_j  Did you put it into performance mode which allows use of DFS channels if you don't live airport or weather station... ...  not sure if your R710 Is fine but mine on average now gets about 550ish to 600mbps on an iPad Pro 2018..... Note, channel fly might take a few days to adapt.  Note, don't use speedflex to check speeds unless you are checking on an AP in which you are not connected via wifi . It gives very inaccurate results on if you are wifi connected to the same AP whiing checking speed flex.  Gives much different results on a different AP.  Best I suggest is testing with iperf3.  What kind of Wifi clients are you testing it with? You can always separate the wifi SSID for one 5ghz and one 2ghz.  oh Also what are you powering it with? POE+ and have you checked if it's in 802.3at mode? Anyway if you getting on average 10-80mbps...... something is wrong... sounds like 2.4ghz connection or somehow you encountered that old speed bug which was a security fix which plagued unleashed firmware 200.7.x.x to 200.8.x.x. I haven't had that issue anymore nor more clients.  

Anyway how old is your home and what kind of materials is it?

New Contributor II

@hayward_kong I've tried performance and compatibility, as well as every other possible option I've found in various threads. And the issue isn't with ChannelFly taking time to adapt, because a) I've had this running for a couple weeks now, and b) there's hardly anything using 5GHz near me, and nothing at all on the frequencies it's using. Also, with regards to ChannelFly, it appears to have a serious issue, because I tried multiple times to transfer a large file over the network to test it, and every, single time it would run (slowly) for a few minutes then the connection would drop, and when it came back I'd see that the Ruckus had jumped to a different channel, despite almost the entire 5GHz spectrum being completely empty, and none of the channels it used had any other usage. So I have no idea why it was changing channels unnecessarily, or why every time it did it causes the connection to break and the file transfer to fail. If it can't happen seamlessly, then what's the point? And to add to the mess that ChannelFly apparently is, after reenabling it, it's now using one of the two small parts of the spectrum with other devices, leaving a large swatch of completely untouched channels unused. Ridiculous.

I personally believe file transfers are the best way to test the true performance of a network, and as I said, I was maxing out at ~480Mbps, and often not even getting that. It also allows for finding issues like mentioned with ChannelFly. That said, I just tested with iperf3, and it's still abysmal. Between 50-150Mbps, and the vast majority between 50-100. (Repeat tests several minutes later achieved ~150-250).

I've tested with my laptop which has an AX200 WiFi 6 adapter and is capable of Gb+ as well as my Galaxy A71.

I realize I can create two separate SSIDs, but I shouldn't have to, it should automatically use the fastest one that has a strong enough signal. And even with using 5GHz only, I'm not even getting 2.4GHz speeds.

I've tried both at and af modes (don't remember which is the preferred one found where I saw it before and that it needs to be at) and it's the same with each. When setting it to af, I get a warning that not enough power is supplied, which is interesting because I'm using a Ruckus 24V/0.5A POE injector, which is both what I read is needed, and supplies the same 24W that the label states it requires (12V/2A) for the DC adapter. So apparently yet another issue with this thing. Regardless, AFAICT based on the manual, speed isn't impacted by not having enough power, at least not on 5GHz, though it's not really clear. Also, I thought the af/at problem was going to be resolved in the .8 firmware.

The house is very old, but considering I'm ~3' from the AP with a single wall between me, unless that wall were solid steel (it's not), none of that should matter. Even so, I ran iperf with both devices in direct LOS with the AP from a few feet away in one direction and ~5' in another, and the results were the same.

Another thing I've found is that I get frequent lag when online gaming, and I ran ongoing pings with the AP, the router, the modem, and last night to see which was was having latency spikes when the lag happened, and while there was some decent mix of which one had the issue for any given occurrence--and at least a couple occasions where the ping to the router seemed, somehow, less than that to the AP, which I have no idea how that's even possible--the majority of the issues appeared to be mainly due to high latency with the AP, which I'm guessing was because it was running so slow it was getting bottlenecked, which is just really, really bad, since that's the only thing I was doing at the time.