Showing results for 
Search instead for 
Did you mean: 

Ruckus ICX7150 router not working after power outage

New Contributor

Ruckus ICX 7150-C12P router not working after the sudden power outage. 

1. Tried to disconnect from the Power outlet the ICX-7150 and reconnected.

2. tried to press the reset button 

  1. Removed power from the switch.
  2. Pressed and hold the Reset button while applying power to the switch

Currently no power is being sent to the WAPS upstairs or downstairs and I cannot find the internet signal from the  LEnnar Router . 

I can only “find” the internet signal sent from my XFINITY set up IMG_5335.jpeg



Hi @Help-needed 


Greetings of the day,


Thanks for your response,


Based on the description it seems like your switch is stuck in boot mode. As the factory resetting process doesn't work we request you to perform the software recovery process by using the below guide.


How to perform a Software recovery on an ICX7150 switch


Ruckus ICX Recovery Load boot code from boot monitor


Note: after fixing the issue of the Switch been stuck in boot mode, please perform an upgrade to the code 08095g UFI and upgrade both partitions with the switching code file named SPS08095gufi.bin, so perform the software recovery using the code 08090k with the upgrade image file named SPS08090k.bin, then when the switch is back to normal upgrade to the file SPS08095gufi.bin for both partitions primary and secondary.


1.Upgrade a Switch ICX-7150-C12P using a USB flash drive


2. Upgrade a Switch ICX7150-C12P via TFTP


3. Upgrade a switch via Web GUI (ICX7150 Switch)


Please let us know if you have any queries in this regard.



Best regards,


Lennar Home Community