Showing results for 
Search instead for 
Did you mean: 

Red light stuck on Ruckus R510

New Contributor

I have two Ruckus R510 Access Points in my house. One of them is working fine and the lights are green. The other one is stuck with a red light on the PWR indicator. I tried resetting both my modem/router as well as the switch and nothing is working. I even tried to factory reset the Access Point, but not matter how long I hold the reset button it just remains red constantly. Also, the POE light on the back of the AP is showing a amber color as well as on the switch for that AP.

On the unleashed dashboard it is showing that it is disconnected. 

Can someone please help?



Hi @User123456789 


Thank you for reaching out to RUCKUS Lennar Home Community. 

I trust this message finds you well.

We appreciate the information you've provided regarding the issue you're encountering.

Based on the description provided, it appears that one of your RUCKUS Access Points (APs) is displaying a Red PWR LED, indicating a potential issue.

To address the connectivity issue with your RUCKUS Access Points (APs), I recommend the following steps:

1. Please unplug the ethernet cables connecting your RUCKUS Access Points (APs) from the current ports on the RUCKUS ICX-7150-C12P Switch.

2. Plug these ethernet cables into any other available 1-in-12 ports on the switch, as illustrated in the screenshot provided.

3. After repositioning the cables, proceed to reboot the RUCKUS Switch by unplugging it from the power outlet and then plugging it back in.

4. Once the switch has rebooted, please verify the APs light and connectivity status.

Please follow these steps and confirm if they resolve the issue.

Thank you once again for your cooperation and patience. Should you require further assistance, please do not hesitate to reach out.


Best regards,

Imran Sanadi
RUCKUS Lennar Home Community

Hello. Thank you for the assistance. I tried these exact steps and repositioned both AP1 and AP2 ethernet cables on the switch and AP1 is fine (green light), but AP2 remains red so this did not fix the issue. Please advise further. 

Thank you. 

Hello @User123456789 


Thank you for your response and the update.

To further troubleshoot the Access Point with the Red PWR LED, I recommend connecting it to an external 12VDC power adapter separately, without utilizing the Switch PoE port cable. You can typically find a suitable 12VDC adapter connected to your ISP's Router or Modem-Router combo device, as depicted in the provided screenshot.

Once connected, please attempt to reset the Access Point physically following the instructions outlined in the following resource:

For guidance on setting up Ruckus Unleashed using the web interface, you may refer to the following YouTube video:

After resetting the Access Point, observe if there are any changes in the LED status.

Thank you once again for your patience and understanding as we work towards resolving this issue.


Best regards,

Imran Sanadi
RUCKUS Lennar Home Community

I have plugged the AP2 into an external 12v power adapter and no matter what I do it will not change from the color red. After I plug it in it is red and if i press the reset button or hold the reset button for 15-30 seconds it remains red and does not do anything else.