Showing results for 
Search instead for 
Did you mean: 

Need RMA for Lennar Device that is connecting

New Contributor

Power light is green but system light is amber and none of the access points have power.  I tried contact to my PC using the eternet cable and USBC cord but none of the solutions worked.  A hard reboot also failed and tried different solutions posted on the community center following the directions which did not work.  



Hi @Micsan352 

Hope you are doing well ! 

Make sure you follow the correct steps while connecting USB (PC) to USB C (ICX-7150 C12P) and install the software correctly.

How to console in the ICX-7150-C12P

Here is the proper Reset process : 

Please try to press the reset button using a paper click or a small stick 

  1. Remove power from the switch.
  2. Press and hold the Reset button while applying power to the switch.
  3. After all the system LEDs flash amber, release the Reset button.

Video link:

Once you confirm this, please let us know.

Best Regards 

Fernando Vasquez 

Thanks for your response— I attempted the instructions which did not work. Please provide next steps. Thanks 

Hi @Micsan352 

The unit Should be RMA (return merchandise authorization) in simple words replace it.

It seems that the management port is not responding since  you have already tried all the steps to gain access to the console.

Feel free to contact us via chat, comment you already have a post, copy the link from the post and paste it into the chat to start unit replacement.

Best Regards

Fernando Vasquez