Showing results for 
Search instead for 
Did you mean: 

ICX 7150 Login Issue after Factory Reset and "no password"

New Contributor

Hi. After an outage, my switch disconnected. When I reboot the system, the primary will not load and the switch boots in Router mode with the secondary. The issue I am having is that I performed a factory reset on the switch and have tried to use the "no password" and "boot" commands repeatedly during reboot but the switch is still asking for login credentials once fully booted. My documentation shows the user as "admin" and the password as "Lennar" which DO NOT work. I have also tried to login using every other default credential mentioned on this forum (super, sp-admin, admin, password, Ruckus!, etc.) with no luck. Could you please advise on how to get log into the switch? I am connected via USB-C through Putty.


Hi burnsworthpa

Greetings of the day!!!

Thank you for the information you shared.

As the ports are working fine for other network cables, 1/1/4 port is only able to transmit 100 Mbps of speed (please refer to the below screenshot) which is a result of a defective network ethernet cable. And this issue/problem is more on the cable side, we suggest you check the cables and replace them with a new cable. Since RUCKUS has no part in fixing the issue related to cable installations.


Thank you again.

Please let me know if you have any queries in this regard.

Best regards,

Imran Sanadi

Lennar Home Community.

View solution in original post



Hi burnsworthpa

Hope you are doing good!!!

Please try gaining access to switch via console and through CLI/console to perform a password recovery. After you have done with the password recovery you can fix the routing code issue.

Please follow the below guide to perform password recovery:

Password Recovery on a Ruckus ICX Tutorial video

Recovery Process:

  1. Console access to the switch.

How to console in the ICX-7150-C12P

  1. Reboot the switch with the console cable attached and press "b" until the following is displayed.
  • Enter 'b' to stop at boot monitor:  0
  1. Using the following commands to remove the password
  • no password
  • boot_secondary


Best Regards,

Imran Sanadi

Thanks for you reply, Imran. I was finally able to go through the process to change my password but the switch is not accepting my new password. I have tried using the login names "admin" and "super" along with my new password but I keep getting a message that says "user login failure". I also keep getting repeated messages that say "TFTP session timed out". Can you please advise? I've been trying to fix this issue for a whole week since the outage with hardly any luck.

Hi burnsworthpa

Thank you for the information you shared.

As your credentials are not working,

Please try by using the below-mentioned default Switch Credentials:

Username: super

Password: sp-admin

If these credentials do not work, please repeat the software recovery process once again.


Now, again reset your new credentials as mentioned in the steps below:

Edit the current or create a new password and username by using the below commands:


configure terminal

device(config)# username super password pass

Where the username is ’super’ and password ‘pass’

In order to allow the correct authentication please run the following commands:

Device(config)#crypto key generate rsa

device(config)# aaa authentication login default local

Now you could try using your New Credentials to log in.


"TFTP session timed out" message appears because the switch is looking for a TFTP server to load the configuration file from the TFTP server but there is no response from the TFTP server so for that reason creates a time out. 

                You can ignore this message if you are not going to download a configuration file from the TFTP server.

Here TFTP is not recommended. Sometimes we may need TFTP to Upgrade the switch via TFTP. And for now, we could disable it to prevent those continuous messages on CLI.

Please perform the below commands:

ICX7150-48ZP Router>enable
No password has been assigned yet...
ICX7150-48ZP Router#config terminal
ICX7150-48ZP Router(config)#tftp disable


If you want that  the message  disappears you can disable TFTP as mentioned above. But you will not be able to do upgrades via TFTP you will have to re-enable it back as mentioned below:

ICX7150-48ZP Router>enable
No password has been assigned yet...
ICX7150-48ZP Router#config terminal
ICX7150-48ZP Router(config)#no ftp disable


Please let me know if you have any queries in this regard.


Best regards,

Imran Sanadi

Lennar Home Community.

Imran, your instructions worked and I was able to create a new username and password. Thank you!! I was able to copy the flash from the primary to the secondary as well as update the FastIron image to the latest version (SPS08095g). My switch is now connected. However, I have two issues: 1. My dashboard is still showing my switch as a router (ICX7150-C12-Router) and 2. My internet is still slow. I should be getting around 200mbps but am currently at around 90mbps. Do you have anything I could try to fix these issues?

I tried to upload and image of my Unleashed dashboard onto this comment but the site says I do not have permission to upload images.