Showing results for 
Search instead for 
Did you mean: 

ICX 7150 C12P Switch

New Contributor

Hi everyone,

I got a house (Lennar) and it comes with ICX 7150 C12P and I tried adding the ethernet cables to the switch so I could connect tv's and computers in different rooms to ethernet. But I'm getting 10 Mbps. How do i change the port to have actual speed to 1G-Full instead of having 10-full. I looked everywhere for an option to change actual speed/mode but I don't see it. Can someone please advise? I want to have ports 1/1/1 through 1/1/12 at 1G -Full. 

If I change configure speed/mode to  1G-full-master or 1G-full-slave speed duplex the port is not available it shows down. 

Image_ images_messages_60bc526d00ea110e398322f1_ffa2a550bfe998dac60935b96041543c_icx7150cp12-1f714110-dad4-41ee-b257-4951126b2df4-795543292.PNG


Hey There, 

It could be a bad patch/termination or cable. Have you tried a different cable run or cable itself? You should not need to set the speed manually. If it negotiates down to 10Mb it is generally due to layer one issues (cable, patching, etc.). 

Ben Beck, RCNA, RCNI, Principal Technical Support Engineer