Showing results for 
Search instead for 
Did you mean: 

Can't reset ICX 7150-C12P

New Contributor

Hi. I just purchased a Lennar home built on 2018 from an original owner. I have no access to the configuration of my previous owner so I am trying to configure the device my resetting it. I pressed the reset button for at least 30 seconds but no lights are flashing as I expected. Somehow, Kevo and other devices that were connected to my Ruckus lost their connection so I am pretty sure there was some change in Ruckus. But I can't still find "Configure-me-xxxx" on my available Wifi list and can't connect to

Please help





Hi @thought31 


Thank you for contacting RUCKUS Lennar Home Community.

Hope you are doing well!!!

Thank you for the information you shared.

As per the case description, I could understand that you need assistance in setting up your RUCKUS setup.

Could you please let us know the answers to the below queries to assist you better?

1. On your switch while it's plugged into the outlet, do you see any lights on? (Amber or green) Please let us know which lights are on. (Please refer to the below picture and share a picture of the same showing the light status and cable connections to the Switch)

2. Is your Internet Connection from the Internet Service Provider (ISP) stable and working? (You could check this by connecting to your local router Wi-Fi or from an ethernet cable from Router to a laptop/PC).

3. May I know how many Access Points are connected to the Switch? Could you please let me know the light status on the Access Points? Any of these lights are on (Please refer to the below picture and share a picture of the same)

Please help us with pictures of your ICX-7150-C12P Switch showing the status of the lights. Also, light the status of Access Points.

Before uploading the photos please log in to the RUCKUS account and you can upload the image.

Please let us know the answers to the above queries or if you have any queries in this regard.

Thank you again for your patience.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.


1. Green lights on "SYST" and "PWR". On the left side, I can switch the light by pressing "Status" button. "STAT", "SPD", "ID", "PoE" are green and "USB" is orange.

2. Internet connection is fine. My laptop is currently connected to the internet. LAN cable from AT&T modem(&Router) is connected to my Ruckus product.

3. Out of 12 LAN ports(access points?), there are 7 LAN ports connected to the device. Out of 7 LAN ports, 5 ports are flashing, some in orange and some in green. Lights on two LAN ports are not flashing.

By the way, I do not have those indicators as you attached below question #3 (no indicators for 2.4gHZ, 5.0gHZ, etc.)

I wish I can upload the photo but website is not providing a feature to upload them. I clicked the camera icon above but all I can is "source", "image descriptions", "dimensions", "Constrain Properties" and I can only type in textx for each blank area. I think there is some error on this feature? I tried MS Edge(using Chrome now) but still the same.

Hi @thought31 

Thank you for the response and the detailed information.

As mentioned in my previous post, please log in to your RUCKUS account on the forum before uploading the pictures.

Please refer to the short guide link below about how to connect the devices:

Most common Setups for Lennar homes users:

Please let me know if you have any queries in this regard.

Thank you again for your patience.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

Hi, I uploaded the pictures below.

Issue I am having is not connecting my device but resetting it so I can configure the device myself since I do not have access to the current configuration from old homeowner who set this up. I need help resetting this device.