Showing results for 
Search instead for 
Did you mean: 

Uplink goes down when AP plugged into switch

New Contributor III

New to Ruckus switches.

Have an ICX 7650 with one uplink to an Extreme switch.  ICX is managed by a SZ100.  When I plug in a Ruckus R650 to a port on the ICX switch, 1 gig or 2.5 gig port, the uplink port goes down.  Show Interface says port 1/2/1 is blocking but gives no indication of why it changed to blocking.  Only way I can get the uplink port to enable is if I reboot the switch. 

If I plug in a laptop into a port on the ICX everything works correctly.  We have one default vlan and four tagged vlans on the switch ports and 5 tagged vlans on the uplink.

I have no idea why plugging in an AP takes the uplink port down.  This is happening on 2 different 7650 switches and am assuming it will happen to all of them.  

Any ideas on what configuration needs to be done so the uplink port won't go into blocking?

Here's part of the show int for 1/2/1 when it's being blocked.

Hardware is 10GigabitEthernet, address is c0c5.2073.3531 (bia c0c5.2073.3531)
  Configured speed 10Gbit, actual unknown, configured duplex fdx, actual unknown
  Configured mdi mode AUTO, actual unknown
  Tagged member of 5 L2 VLANs, port state is BLOCKING
  BPDU guard is Disabled, ROOT protect is Disabled, Designated protect is Disabl
  Link Error Dampening is Disabled
  STP configured to ON, priority is level0, mac-learning is enabled
  MACsec is Disabled
  Flow Control is config enabled, oper enabled, negotiation disabled
  Mirror disabled, Monitor disabled


New Contributor III

So I deleted the configs in the Smartzone for the switch and remade the 5 vlans we need and assigned them to the ports.  Factory reset the switch and reconnected it to the Smartzone to download the configuration.  Same thing.  Plug in an access point and the main uplink goes down.  Only way to get the link to come backup is to reboot the switch. 

Uplink (Port 1/2/1)  vlans are all tagged 128,232,236,240, and 2801.  No default vlan assigned in Smartzone group config.  After the switch was connected, the switch config now shows vlan 1 as the default vlan assigned to ports 1/2/1-1/2/4 and STP is turned on for all vlans, although it wasn't turned on in the Group config.

Any ideas?

RUCKUS Team Member

Hi Jason,

This looks like spanning tree blocking the redundant ports to avoid a potential loop.

Pls verify the stp configuration on the ports to ensure they are set right. 

There are no redundant uplink ports.  Port 1/2/1 is the only uplink to the next switch. It only carries the wifi vlans, no management vlan.

Could the management port, which only has one vlan and is not on Port 1/2/1, be causing the issue?  There are no other ports being used when I plug in the AP.  STP is on right now for all normal ports and uplink.  What should it be?  I have tried with it off and on all ports and the uplink still goes down.

I have worked with Cisco and Extreme switches and never had this issue.  Is there something with Ruckus switches that's different in how they handle STP?

Hi Jason, what kind of software are you running. We had a similar issue with ICX and R550, the latest ICX 8.0.95 version in combination with 5.2.1 build 1038 was made the ports flap

We downgraded the switch firmware to 8.0.90j