Showing results for 
Search instead for 
Did you mean: 

Routing Public LAN (/28 block) over Peer to Peer (/29 Block) Gateway Connection

New Contributor

Comcast ran an EDI circuit (Metro Fiber) to our office. They originally gave us. /29 block but we needed additional public addresses. I am able to assign any of the useable addresses from the /29 block and use the gateway that is in the same subnet without any issues. What is new for me and where I am lost is doing the routing statement from the /28 block which is disjoint from the /29 block.

/29 block = xx.xx.68.249/29

/28 block = xx.xx.135.16/28

I have a ruckus ICX-7150 with the switch firmware on it. I have a sfp+ module in 1/3/3 that connects to the Ciena "modem" from comcast I have assigned it the IP address of xx.xx.68.250

I have then connected a USG to and assigned the copper 1/1/1 port to xx.xx.135.17

I've tried issuing quite a few different "ip route" statements. I have tried a lot of other things that have failed as well. I am able to get my macbook pro running OSX 14 to connect and route correctly on the /28 block when I have it connected to the 1/1/1 port with the statement "ip route xx.xx.135.16/28 xx.xx.68.249" and setting the static on my macbook to xx.xx.135.18/28, it will not connect right away and it takes about 30-90 seconds but after that it is able to connect and the public address shown when browsing is off our /28 block.

I am getting to my wits end and have tried anything I can think of and read everything I can about this as its just outside my capabilities. I feel like I'm incredibly close and if anyone could spare there time to either tell me what I'm missing or at least guide me in the correct path I would be forever grateful.