Showing results for 
Search instead for 
Did you mean: 

Problems With Trying To Update ICX 7150-C12P Switch To FastIron 9

New Contributor

Hi all,

I’ve had a hell of a time trying to get an ICX 7150-C12P Switch to update to FastIron 9, so that I can use it with Unleashed.

I followed the Guide here: and it seemed like I was able to go to SPS08080f.bin and mnz10114.bin, then to SPS08095mufi.bin on the Secondary Partition.

Then I tried to flash SPS09010jufi.bin so I can add the Switch to Unleashed, and got this error: "the code type 64 is not correct for the target hardware abort".

Also, I was prompted to change the password, which I did, but then I couldn’t log in no matter what I tried, i.e. username: super, password: sp-admin, password: “the one I set”, username: admin, password: Lennar.

And now, it looks like there's data corruption. I got this, for example: Resources partition is factory-corrupted! Formatting!! Formatting will destroy all the certificates and licenses!!

and also:

WARNING: Boot-monitor version mismatch!!! ========== ========== Please use "show boot-monitor" command for details =

I don't know if that's from unplugging, and plugging the Switch back in to power cycle it so many times. It could also possibly be from trying to factory reset the switch, which I was also having difficulty with.

However, I was able to use the "no password" command to get back to the "ICX7150-C12 Switch>" prompt, and it has currently booted the Primary partition:

System initialization completed...console going online. Copyright (c) 1996-2017 Brocade Communications Systems, Inc. All rights reserved. UNIT 1: compiled on Feb 17 2017 at 16:03:13 labeled as SPS08060 (23946048 bytes) from Primary SPS08060.bin SW: Version 08.0.60T211 Compressed Boot-Monitor Image size = 786944, Version:10.1.14T225 (mnz10126 ) Compiled on Thu Nov 15 12:59:22 2018 HW: Stackable ICX7150-C12-POE

I’m pretty exhausted from trying to troubleshoot this at this point, and I’m hoping to get some guidance on a smooth and clear path to get the Switch running on FastIron 9, so that I can set it up in Unleashed.

Please let me know what to do, thanks.



Hi Imran,

Thanks, I hope you're well too.

I was able to update the Switch to FastIron 9, however, I'm now having the problem described here, when trying to adjust the AP Settings:

My post is at the bottom of that thread. What is the solution to that problem?

Thanks for your help.