Showing results for 
Search instead for 
Did you mean: 

Problems With Trying To Update ICX 7150-C12P Switch To FastIron 9

New Contributor

Hi all,

I’ve had a hell of a time trying to get an ICX 7150-C12P Switch to update to FastIron 9, so that I can use it with Unleashed.

I followed the Guide here: and it seemed like I was able to go to SPS08080f.bin and mnz10114.bin, then to SPS08095mufi.bin on the Secondary Partition.

Then I tried to flash SPS09010jufi.bin so I can add the Switch to Unleashed, and got this error: "the code type 64 is not correct for the target hardware abort".

Also, I was prompted to change the password, which I did, but then I couldn’t log in no matter what I tried, i.e. username: super, password: sp-admin, password: “the one I set”, username: admin, password: Lennar.

And now, it looks like there's data corruption. I got this, for example: Resources partition is factory-corrupted! Formatting!! Formatting will destroy all the certificates and licenses!!

and also:

WARNING: Boot-monitor version mismatch!!! ========== ========== Please use "show boot-monitor" command for details =

I don't know if that's from unplugging, and plugging the Switch back in to power cycle it so many times. It could also possibly be from trying to factory reset the switch, which I was also having difficulty with.

However, I was able to use the "no password" command to get back to the "ICX7150-C12 Switch>" prompt, and it has currently booted the Primary partition:

System initialization completed...console going online. Copyright (c) 1996-2017 Brocade Communications Systems, Inc. All rights reserved. UNIT 1: compiled on Feb 17 2017 at 16:03:13 labeled as SPS08060 (23946048 bytes) from Primary SPS08060.bin SW: Version 08.0.60T211 Compressed Boot-Monitor Image size = 786944, Version:10.1.14T225 (mnz10126 ) Compiled on Thu Nov 15 12:59:22 2018 HW: Stackable ICX7150-C12-POE

I’m pretty exhausted from trying to troubleshoot this at this point, and I’m hoping to get some guidance on a smooth and clear path to get the Switch running on FastIron 9, so that I can set it up in Unleashed.

Please let me know what to do, thanks.



RUCKUS Team Member

Hi Akhen,

Thank you for reaching us.

Could you please confirm us if you are from Lennar Homes.

For Lennar accounts we have a separate page where you can always feel free to reach us and post your queries.

Please refer the below link for posting your queries for Lennar.

I hope this information helps you

Please feel free to leave us a message if any concerns

New Contributor

Ok, please move this over there, thanks.

EDIT: Actually, I was able to get this resolved. Are certain characters not allowed for passwords?

RUCKUS Team Member

@Akhen Ack and noted will move your query towards Lennar Homes.

Regarding your query on password characters, Please refer to the below link for your reference.


Hi @Akhen 

Greetings of the day!!!

Hope you are doing good.

Could you please update on the status of the issue?

Please confirm and let us know if you need any help in this regard.

Thank you again for your patience and understanding.


Best regards,

Imran Sanadi

Lennar Home Community.