Showing results for 
Search instead for 
Did you mean: 

Configuring ICX 6430-24 for media streaming?

New Contributor III
Hi Folks,

I'm very new at this, and Ethernet is not in my "day job".  I just got my first managed switch, a used/surplus ICX6430-24.  I used it to upgrade a un-managed 10/100 switch that had been in place for 10+ years and was hoping to enjoy the benefits of manageability and 1Gig speeds.  So far, its just given me headaches.

I've tried to read as much as I can before posting this, but I'm just not well versed in the newer ethernet standards to keep up and understand all of it, so I'm hoping someone here might be able to help.

My 6430-24 is running the ICX64S08030sa code image.

I've got 3 DirecTV devices (HR-24, HR-22, H-23) all connected to this 6430-24 for Multi-Room Viewing (streaming a recorded show off of one receiver over to the other).  When using the 10/100 switch that's been in place for years, everything works fine.  As soon as I swapped in the 6430-24 things went wrong.  Now the Multi-Room viewing is basically unwatchable as I'll get 3 to 5 seconds of picture with audio, then a 30 to 60 second freeze, and then some picture with no audio.  Then it syncs up for about 3 to 5 seconds, and the cycle repeats.

I'm assuming I'm loosing ethernet frames somewhere and that the DirecTV receivers don't ask for re-transmission of the lost frames due to performance reasons.  I'm looking for some help in 6430-24 tuning to see if I can fix this up.  My PC's, DVD Players, X-Box 360, and Wii can all stream Netflix, Amazon Video, and YouTube just fine, so what ever the issue is its just affecting the DirectTV receivers.  


Things I've tried so far (none of which have made a difference)

  1. Reset the 6430-24 switch to factory defaults and loaded latest firmware (8.0.30sa)
  2. Locked the ports to 100 Full duplex for the 3 ports connected to the DirectTV Receivers
  3. Enabled 802.1q rapid spanning tree and designated the 3 ports connected to the DirecTV receivers as Admin-Edge-Ports to avoid any spanning tree learning (since the HR-22 has a built in switch in it)
  4. Moved the 3 DirecTV ports on the switch into the Highest QOS level (qos6).
  5. Moved all other ports into the lowest QOS level (qos0).
  6. Increased the global buffers and queue descriptors
  7. Increased the qos6 level's buffers and queue descriptors
  8. Switched into Fully Synchronous Flow Control (which disabled the buffer tuning in steps 5 and 6 above)
  9. Verified that the 3 ports connected to the DirecTV receivers are not generating any errors.
  10. Run the built in TDR functionality of the switch on all 3 DirecTV connected ports.  No cable faults were found.
  11. Switched to different ports on the 6430-24.
  12. Run a very long Cat6 patch cable directly from the 6430 to the DirecTV boxes to bypass all of my patch panels, in wall wiring, etc.

I'm running Cat5e inside the walls, with Cat5e keystone jacks, or patch panels (depending on the end of the in wall cable) and Cat6 Patch Cables.  The same cables work without issue if I switch back to the no name 10/100 switch (but I do recognize that 1G uses all 4 pairs, and 10/100 only uses 2 pairs).

I don't think I'm doing anything "exotic" with the 6430 that would put a high load on it causing it to drop frames.  Memory is only 61% used, and the CPU utilization only shows 1%.

Does anyone have any experience on running media streaming applications over 6430 switches that could point me in right direction on how to "tune up" or configure them for best performance? 

I'll happily supply any needed data/outputs if requested.

Thanks in advance! --Brian


Contributor III
Please post a "show int e 1/1/1" or whatever interface you have the device(s) connected.  I want to see if there are any errors such as CRC errors.

Also, can you set the devices to auto speed and duplex and the switch to auto speed and duplex and test that?

Have you verified the network cabling will run a 1 Gbps?

New Contributor II
What version of code are you running? 

New Contributor II
What version on code are you running, We add issues with multicast until we updated. 

Just saw ver 8.0.3a in your notes   _ had issues with this ver, went to ver 8030r.