Showing results for 
Search instead for 
Did you mean: 

vsz fw 3.6.2 to standalone FW - problems flashing (r500) - (or what is proper process?)

I thought i had done this path before (ie i have a r500 with vsz FW 3.6.2.x  and trying to flash it to standalone FW , ie 110.x),  but maybe this is my first time going this direction.

Im having issue getting this done (and maybe its bc of the change ~ vsz 3.5 to signed FW?).

Of course in the vSZ AP FW's gui there is no option to change or upload any FW (assuming you have enabeled http/s via ssh on the AP),  so i decided to try to flash its FW via SSH w FTP:

However after a reboot, the AP still comes back up with 3.6.2  (have also tried pressing button 7s to factory defaults, and trying again, same result).

Any ideas?  Or what is the proper process to flash a AP with vSZ FW to Standalone FW?


here are the logs from the flash process via ssh (which is the only way i can see is possible to flash it), note: after the reboot, the ap still has the same vsz FW (not standalone 110.x), and both FW banks on the AP are the vsz FW, 3.6.2.x):
rkscli: fw set port 21
rkscli: fw set control r500_110_cntrl.rcks OK rkscli: fw force-update fw: Updating rcks_wlan.main ... v54_fw_update: download section=rcks_fw.main image=Image1 ctl_file=zf7372_104_cntrl.rcks (/writable/fw/main.cntl) flash id is 0x10220 imghdr.{hdr_len=160, bin_len=10970972} fw_flash_read_open: open((null),) failed rks_flash_read_open(1) failed tail_offset 10968928 bin_len 10970972 sign 1. fwcheck is 2. net_get_flash, Upgrading from Fully Signed Image(FSI) to Intermediate Signed Image(ISI) image. Firmware size mentioned in control file(10971132) _erase_flash: offset=0x0 count=42 Erase Total 42 Units Performing Flash Erase of length 262144 at offset 0xa40000 done [====================================================================================================] 100 + read_size 8192; rc=2044 net_get_flash: Receive last block buf 2044 net_get_flash: hdr_fsize=10969088, real_fsize=10969088 net_buf 0x7ffe3914 Reading Image TAIL:- TLV No-1.TLV INFO Number of TLVS in Tail is 2. Size of Tail is 2044. len 9 tail_len = 9 2. SIGNATURE OBTAINED SUCCESSFULLY len 259 tail_len = 268 cert len 1773 pass 3. CERTICATE OBTAINED SUCCESSFULLY len 1776 tail_len = 2044 1444: rc1 2044 tail_len 2044 MD5 Checksum successful!!!!!!!!! Checking Image hash:- 1. Obtaining public key from Certificate. Executing openssl x509 -in /tmp/in_cert.pem -pubkey -noout >/tmp/pubkey.pem line: Certificate will not expire Certificate validity verified. line: /tmp/in_cert.pem: OK 2. Public key verified. 3. Decrypting the Image signature. Executing openssl rsautl -verify -pubin -inkey /tmp/pubkey.pem -in /tmp/signsure.bin -out /tmp/ext_sha256. 4. Comparing the signatures:- IMAGE TAIL SHA256 : 0a359971c5e62baa9e82a6aac681e922fca8a3ed6b8efb45b35333292781bd45 CALC SHA256 : 0a359971c5e62baa9e82a6aac681e922fca8a3ed6b8efb45b35333292781bd45 HASH CHECK PASSED. AIS cleanup : Removing /tmp/ext_sha256... AIS cleanup : Removing /tmp/in_cert.pem... AIS cleanup : Removing /tmp/signsure.bin... AIS cleanup : Removing /tmp/pubkey.pem... AIS cleanup : Completed bdSave: sizeof(bd)=0x7c, sizeof(rbd)=0xd0 caching flash data from /dev/mtd3 [ 0x00000000 - 0x00010000 ] updating flash data [0x00008000 - 0x000080d0] from [0x7ffea158 - 0x7ffea228] _erase_flash: offset=0x0 count=1 Erase Total 1 Units Performing Flash Erase of length 262144 at offset 0x0 done caching flash data from /dev/mtd3 [ 0x00000000 - 0x00010000 ] verifying flash data [0x00008000 - 0x000080d0] from [0x7ffea158 - 0x7ffea228] **fw(1726) : Completed rkscli: reboot OK rkscli: exit Quit: OK Connection to closed.

EDIT- to be clear (and for future/others that may come across this issue)-  INITIALLY (before reading replies here, or reaching out the ruk support): regardless of what i tried/did i could never get the upgrade option/llink to show up in the APs web gui (like it normally does).  Even it did show up, im not sure that the FW update via web gui would have worked. (i assume it would have done the same thing as when i used ftp method to try to update its fw).  Ive changed FW on *many* (100s - 1000s) of ruk aps over the years, but have never seen this particular issue, especially on a later/more recent vSZ FW based APs.  (i just wanted to clear that up for others in future, this wasn't a simple use the APs web gui to update/change fw. - tks) 

thanks all for the GREAT replies.  I was able to get the AP back to standalone via ruk support's help (they did the generate shell key method).

However ALL 3x replies are GREAT info to know for the future, as we deal with alot of ruk APs.  I have added all 3x replies to my notes.  

Jonathon-  I didnt know that on a vSZ FW based ap, if you DISABLE scg services, this may trigger the upgrade option to appear in the web gui (thank you, + this makes sense from a security standpoint too)

Michael-  The upgrade option/link was not showing up anywhere in the APs web gui (like it normally does).  i cant 100% recall, but i *think* i ALSO may have tried upgrading the APs FW via the vSZ controllers web gui, in my troubleshooting, but the standalone FW still would not take (or vsz web gui threw an error).  I dont recall why or the error. Thank you.

Abilash-  the upgrade option/link was no where to be found in the APs web gui while it had vSZ FW 3.6.2 on it, but perhaps i needed to try Jonathon's method and disable scg service first.  I also generally use ftp and not tftp when FW updates are needed outside of the aps web gui (maybe i should have tried tftp also though, but i would assume result would be same as ftp).    in the end support had me do something similar to what you described (gen. a shell key, to allow me root/shell access to ap)

thanks again all.

Thanks for sharing your detailed feedback too.

Contributor III
Thanks for the detailed update Stephen, glad to know that your issue got resolved. Let me try to upgrade one of R310s to 3.6.2 and see if I can flash it back using 110 and post results here.

Abilash PR.