Showing results for 
Search instead for 
Did you mean: 

ZoneFlex R500 keeps disconnecting from Ethernet

New Contributor
Hi all,

I have an R500 that occasionally drops traffic for periods of about 5 seconds at a time. This happens maybe a couple times a day, but it's quite noticeable when I'm streaming music and it just drops out.

The key bits in the log are as follows:

Mar 13 18:02:19 R500 user.warn kernel: Enet:0 port:4 down
Mar 13 18:02:19 R500 user.warn kernel: 955x_GMAC: unit 0: phy 4 not up carrier 1
Mar 13 18:02:19 R500 kernel: br0: port 1(eth0) entering disabled state (events/0,5)
Mar 13 18:02:21 R500 user.warn kernel: Enet:0 port4 up
Mar 13 18:02:21 R500 user.warn kernel: 955x_GMAC: enet unit:0 is up...
Mar 13 18:02:21 R500 user.warn kernel: eth0  RGMII  1000Mbps  full duplex

You can see that the port comes back up almost immediately after going down, but during that time it basically doesn't work. I'd thought there might be an issue with the PoE switch or the ethernet cable, but I've tried a different switch and a different cable and I still see the issue. And it stays powered the entire time, it's not like there's an issue with power delivery.

The R500 is running latest firmware,

Any idea what could be causing this?


Valued Contributor II

it possibly could be a half-duplex issue... make sure no duplex setting is fixed on switch port for AP and duplex setting should be set to default/auto

Contributor III
Is it possible to see the swich logs from the same time as this. You will be more likely to find the reason by looking at both ends of the link rather than just the AP side. What switch do you have the AP connected to?

New Contributor
I've tried two unmanaged PoE switches- one from Linksys and one from Netgear. But I just ordered a managed switch for testing, so hopefully I can sync up the two logs if the issue continues. Or maybe I just got two flaky switches in a row. Stay tuned.

New Contributor III
Hi Andrew, I have come up against this before in the past and usually it's an issue at the physical layer. However I did also experience a faulty AP where it does exactly what you've just said. Can I just check if the switch and the access point are in the same location or if you are using structured cabling from switch to the AP? If you want a decent switch to test from a Netgear GS110TP is great as it's PoE and has a decent web GUI plus you can see port errors or issues with PoE. You can also purchase PoE Injectors which would allow it to work from any switch. Good luck