Showing results for 
Search instead for 
Did you mean: 

ZF7343 with AppleTV3 and iPad 3 - AirPlay very unreliable

New Contributor II
Hi there,

A home network is set up with a ZF7343 AP (no ZoneDirector) for wifi access (firmware version, and for the most part, this works extremely well - wireless performance is excellent even when many many devices are online.

However, there is an Apple TV 3 (current firmware) that we're having trouble to get AirPlay to work consistently with. There are two iPhones (4S and 5) and two iPads (2 and 3) commonly used in this house. All of them see AirPlay available only every now and then, mostly right after the iOS device or the ATV unit have been rebooted, but not always then either.

Once they do see AirPlay on their units, playback is smooth, but sometimes it just disappears.

No password for the AirPlay functionality is defined.

Neither the ATV nor the i*-devices have any general network trouble - they can access for instance Netflix with no problems.

"Packet Forward" for the WLAN being used is set to "Bridge to WAN". Since both the ATV and the iOS devices are connected through WLAN, I'm thinking the problem could be here, but that is just a guess.

Any ideas on how I could approach this?

Very thankful for any suggestions!

Valued Contributor II
Hi Rune, sorry for the delay. I'm going to guess this has something to do with directed multicast. In wireless you don't want "true" broadcast/multicast typically in order to preserve bandwidth. This article should help -

New Contributor II
Hi Keith,

Thanks for your reply!

I tried to follow the article, and used putty to ssh in. But the commands in the article didn't work - could this be because I have a later version?

The one that looked the most like what is described in the article was this one:

set qos directed multicast {enable|disable}
-- Sets the state of egress packet processing for the specified interface

So since my AP is connected to eth2, I did this:

set qos eth2 directed multicast disable

But nothing else. The issue is still there, but of course I have a few more questions;

1) Was that the right command to use? In mine I had to specify the ethernet interface, in the one on the web they said to specify the ssid.

2) Do I need to do anything equivalent of "enable" to get the setting to take effect?

Thanks for the help so far, hoping I'm just a few technicalities away from permanently working AirPlay. 🙂

New Contributor II
I read up a little more on this, and understood that I should probably do it on wlan0 (the WLAN I actually use) instead of eth2... I think I did it, but no airplay, except that it shows up randomly now and then.

rkscli: get qos wlan0
Ruckus Wireless SmartMedia QOS info for wlan0 interface

QOS Configuration options:
Classification: Enabled
UDP Heuristic Classification: Enabled
TOS Classification: Enabled
Dot1p Classification: Enabled
VID Voice Classification:
VID Video Classification:
VID BE Classification:
VID BK Classification:
Dot1p Classification VIDs:
Dot1p Marking VIDs:
Directed Multicast: Disabled
IGMP Snooping Mode: Enabled
MLD Snooping Mode: Disabled

General Mcast->U Cloned Filters TOS-Mark
Stats 14 14 0/0/0 0/0/0/0

L2 Mcast Packets Unicast Unk-Drop Known-Mcast
UDP Data 79855 28 79841 307590

Heuristics Voice Video
UDP Packets 423 0

IGMP/MLD Clone1/2/3
Errors 0/0/0

No Filters are currently defined on wlan0 interface

Any ideas? Should I do a Wireshark capture to see what is going wrong? In that case, how to do that from a single AP?

Valued Contributor II
Sorry Rune - I sent you the ZD CLI commands and the AP's are a bit different:

Standalone AP:
set qos wlanX directed multicast disable
set directed-thr wlanX 0

where X is the wlan AirPlay is on, use ‘get wlanlist’ to see configured WLANs.