cancel
Showing results for 
Search instead for 
Did you mean: 

Ruckus R510 speeds slowing down to 10 or less Mbps

garrett_william
New Contributor III

I've been experiencing some WiFi slowdowns. I started testing with iperf3 and my iPhone 11 Pro. When I'm under the R510, speeds will get up to 550+ Mbps. If I walk about 15'-20' away, with two walls between me and the AP, the inital speed tests run around 250-350 Mpbs. During the 30 second test though, speeeds rapidly drop down to less than 10 Mbps, sometimes to zero.

Without changing anything but the R510 to a different brand access point, speeds went right back to ~250-350 Mbps. I swapped the R510 back and things went back to as before. I tried removing the upstairs R510 and only running the downstairs R510. I tried swapping the upstairs R510 to the only downstairs unit. No change.

There are 2 R510's in my 2 story home, both POE off a Ruckus 7150-C12P. The only other POE device is a Ring doorbel. I tried all sorts of stuff, including a factory reset via downgrading the firmware (from 200.12.10.5.234 to 200.11.10.5.195). I tried rebooting my iPhone, forgetting and adding the network SSID back, creating a new SSID, turing off 2.4Ghz, fixing the channel number to an unused channel in my area (from Auto), fixing channelization to 40 MHz (from Auto), fixing transmit power to maximum (from Auto). 

Sometimes, dropping the WiFi on the iPhone and starting it resets the process. If I walk the iPhone to back under the R510, it quickly speeds back up to ~550Mbps. Changing time of day or day of week does not impact results. I've tried two different devices for the test and the results do not change.

 

From the troubleshooting log while I just tried two more 30 seconds iperf3 tests, it appears the iPhone is bounching between the two R510 access points. There are no "red"entries at all. However, the problem was the same when I only had one access point plugged in.

*Ran the test AGAIN with the further AP disconnected. Same behavior. Peak was 310Mbps at one point. It flopped down below 100Mbps, jumped back up for a few seconds, then dropped down to 30Mbps. From there, the last 10-15 seconds of the test just got slower and slower, ending at 5Mbps.

The iperf3 tests were conducted with the phone in a tripod, with no one in the area, between the R510 and the phone, and no other devices competing for bandwidth at the time.

 

I'm at a loss. Any help would be appreciated. If the AP is failing, I'd love some way or test to confirm that. 


- Garrett
2 REPLIES 2

gary_fixelle
New Contributor

You may want to consider segmenting your 2.4 and 5.0 networks  2.4 will have greater range but the performance is awful. 5.0 will give you much better performance  create a new network name and simply add5k to the end and segment the network and only try to connect to the 5K network for best speed performance

syamantakomer
Moderator
Moderator

Hi Garrett,

I hope there are no other Wi-Fi access points close to your home which may be interfering with your APs signals.

Couple of thing which I would suggest as standard configuration practice:

  • Install the AP to most open area with less number of obstacles (I know, it may not always be possible).
  • Choose central location for better coverage.
  • For speed hungry devices, prefer 5G vs 2.4G
  • If you have multiple APs in the network, make sure signal overlapping is good (not too high, not too low). About 25% signal overlapping between two APs works well in most of the installs.
  • In multi AP environment if clients are connecting to far APs, enable BSS minrate and set to 12Mbps or even 24Mbps.

For the troubleshooting purpose, check the client's signal strength in AP at the time of poor speeds. Current MCS rate will help here.

Also, output of below commands (collect at the time of slow speed) will give us more info about the client status.

  • get station wlan1 stats all
  • get station wlan32 list all 
Regards,
Syamantak Omer
Official Rep | Staff TSE | CWNA | CCNA | RASZA | RICXI
Labels