Showing results for 
Search instead for 
Did you mean: 

R510 Unleashed Clients no getting IPs from DHCP

New Contributor II
There is an r710 connected to the same switch and doesn't have the same problem.
When I assign a static IP to the client there is still no network access.
The only thing that works is enabling 'randomized MAC' on the client, that way it gets an IP from DHCP no problem.
Also this is on my default WLAN / VLAN, i have another WLAN on a different tagged VLAN and that one doesn't have the same issue on the same AP.

What could be the problem?

RUCKUS Team Member

Could be a VLAN config. The switch port where is the AP is connected, is it configured as Access or Trunk port? If you are passing multiple VLANs, configure it as trunk port.

If the switch port config is fine, do a packet capture (using wireshark if possible) on the DHCP server side to see if it is receiving the traffic from the client.

New Contributor II
Since setting a static IP on the client doesn't give connectivity it's not a DHCP problem.
Neatgear switch GS110TP V3.
My management/main VLAN is 1, guest is 10.
VLAN 1 in untagged  on all ports VLAN 10 is tagged.

I tried tagging VLAN 1 on the port r510 is connected to, it didn't solve the problem.

Again exact same setup works on r710 connected to the same switch.
No idea what else to try.

Also the fact that randomized mac allows access and native device mac doesn't is strange.

New Contributor II
Got an r720 to replace the r510, same thing. Pretty sure it is an unleashed specific bug.

Basically when there is a WLAN on the default VLAN1 (which us UNTAGGED)and another WLAN on a different VLAN (TAGGED) on the same unleashed network clients connecting to the SLAVE, get no access to the network unless they use a random MAC. Clients connecting to the MASTER can have random or native MAC.

TAGGING VLAN1 on solves this issue.
This is 100% reproducible for me by switching the master/slave AP in my network of two APs.

Does this need to be filed as a bug somehow?

New Contributor II
Issues came back. Tagging VLAN1 didn't solve it.