Showing results for 
Search instead for 
Did you mean: 

R510 Access Point not powering on

New Contributor

I have 3 Ruckus R510 APs and one of them stopped working.  I have tried powering down and restarting the Ruckus System, but, only 2 of th APs powered up while 3rd did not.  I tried disconnecting the ethernet cable and plugging into a different port on switch, but, that AP still did not power up.  I removed the AP from the ceiling and tried connecting it to the switch with a brand new ethernet cable that i know works (as i tried it on other devices as well), but, the AP did not power up.  What other steps do I need to take?


RUCKUS Team Member

Hi @CMMall ,

I see that you have already tried basic troubleshooting with APs and one of them is still not powering up. Suggest you try the below steps:

Is Poe being provided with the proper AP port?

Correct cable type (cat5/6) and distance between switch and AP?
Does an alternate switch port work?
Does the switch configuration provide the proper POE class?
Does another AP work on the same port?
POE budget issues?

If any of the above does not work, please create a support case to proceed further with the RMA process based on the warranty present for the problematic AP Serial Number.

What are Ruckus' Support Offerings? 

Please refer to the Warranty terms by Ruckus. 

Please let me know if you have any quires.