Showing results for 
Search instead for 
Did you mean: 

I get the "bad firmware header magic" error message when i try to upgrade T300 AP from 100.x to 104.x

New Contributor III

New Contributor III
@Joke Jong, extract that compressed folder the you will find a lot of .bin files for different access points the pick the .bin file of your AP and upload it, that is how i managed it

New Contributor III
I think you meant BL7 files and not bin files. We uploaded the BL7 file and not the ZIP or any other file formats.

New Contributor III
oh sorry, i mean those BL7 files, 

New Contributor
We have two ZD 3050's that are on build 15.  we cant upgrade the firmware, because we have older AP's and will lose them (maybe 30 of them), but below is what i emailed into a ticked i opened with ruckus (ive had no reply in THREE days from them, im in a back hole i suppose), anyway, have a read and give your thoughts (Sorry its a long one):

We bought two R500 Access Points about a year ago, and those are our spares.


Within the last three to four months we bought four new R500 AP’s for a new building that will be coming on line soon.


It’s the new R500’s that im trying to get to join the ZD, and ive tried two of the four, and they will not join the ZD, and that’s what this open ticket is about.


When I upload any firmware version, whether its version 100 (which you had me try) or version (the latter being and older version to what we are running), after it does the update which is states is successful, and returns to the main login AP screen, it still shows it version as  Meaning NONE of the firmware updates actually “takes”, and ive tried EVERY version of firmware below 104.


So, I decided to try the same thing using the R500’s that we purchased about a year ago.  The first thing I did was to see if I could put the version of the firmware onto it.


Well, it WORKED, it took that version without issue, and when I plugged that AP into our live network, it updated to and joined the ZD without issue.


This leads me to believe that the newer R500’s that we bought, have some fundamental hardware difference, that isn’t allowing the update/downgrade to ANY firmware version (it seems “stuck” on version .  I have tried the upgrade/downgrade on THREE of the four newer ones, and so far ALL THREE wont upgrade/downgrade.  They all go through the process, state it was successful, but when I log into them, they still show the 104 version of the firmware, and NOT the one I just uploaded.

UPDATE: i got one of the four (newer ones) to get to version but i cant get it any further down, i get that "bad firmware header magic" error!

if this is because of a newer chipset, this is a HUGE issue and needs to be addressed by Ruckus.  Ive got a building coming on line, and NEED those new R500's on the ZD....

Thanks Mike,

    This is valuable feedback and if you have a ticket open, share these downgrade problems.
I think it's more firmware however, than hw/chip set issue, and version 104.x Solo AP image
came out much later and would have been close to ZD 10.0 compatibility.  

   Since your ZD3Ks are running, please try to flash the APs with Solo AP 

   You say above you couldn't downgrade some APs, but try the FD a couple times... I also
advise direct connect between AP/PC if you have a power adapter, or just your PC/AP on
a little PoE switch.  

   If you are successful, try to load the 9.8.2 code a 2nd time.  There are 2 banks of memory
in APs, that hold config/firmware data, and you want to permanently erase any 104 remains.
I hope this is helpful.