Showing results for 
Search instead for 
Did you mean: 

How to force the change of channel when it's "not optimal"

New Contributor II
We are using pairs of 7731 to interconnect some branchs to our main offices (there are 23 pairs in total).

Sometimes these links do not perform well (our monitoring tool shows packet losses and the users complain about).

I took the device log during a fail, and I noticed messages like below:

  • (...) wifi0: Interference detected: util_busy: 327 > 300, badness=1

  • (...) wifi0: RB thinks Ch.100 is not optimal. Best available is Ch.124. Reason: non-blacklisted channel found

  • (...) wifi0: RB won't change from Ch.100 to Ch.124 (warn-only).

  • (...) wifi0: Interference detected: tx_lretry: 1398 > 1000, badness=0

We are using the "SmartSelect" channel, but it didn't change the channel automatically. The problem persisted for 2 hours, and the solution was reboot the root bridge device.

Is there an option to force the change of the channel when that occurs?

Bruno Fonseca.

New Contributor II
But these 23 pairs aren't on the same building.

For example, the latest case (that I extracted the part of the log file referred here) the main building has 5 root bridges on your top, with 3 branches on the neighborhood (2 with 2 non-root bridges, and one with 1).

New Contributor II
We had used the channel optimizer when we did the installation, for this specific case about 4 months ago.

The problem is happening right now, the image below shows the results of our ping test (packet losses [red] vs response time [green]).

Image_ images_messages_5f91c416135b77e247956cce_9a04e1ce1e2ca892ca7a4ec7a453ff09_PacketLost_vs_ResponseTime_inl-e92cb8f3-0672-400a-92ee-04146c5cb118-397676444.PNG1389623516

The messages on the log show the same error, indicating interference in channel 100 and suggesting the change to 124.

Is it possible to let the device change the channel "on-the-fly", automatically? I thought that the SmartSelect channel supposed to do that.

Contributor III
I don't know the answer to your question.
I only have 1 mesh link in my environment and I don't see any channel changes for the mesh link it in my logs. (for the past 2 weeks)

I recall setting things up so the meshed AP had a 5Ghz mesh and only accepted clients on 2.4Ghz..
If you're accepting clients on the 5Ghz side (same frequency as the mesh) you could be causing yourself problems.

Valued Contributor
@Bruno I have said this many times before on this forum, but have you used a spectral analyzer to check what is going on? If I'm reading your logs correctly the channel is getting over-utilized. RW have set a limit of 300 and your bridge is getting over that (327). So there is interference from somewhere. Now it might be your own (from other bridges) or from somewhere else (not your bridges).

Why wouldn't it chenge from 100 to 124 I don't know quite exactly, but I don't think the 7731 changes channels at all.

Valued Contributor

Probably not related, but are there any DFS mentions in the logs?