cancel
Showing results for 
Search instead for 
Did you mean: 

ZD 1200 Google Maps array.from error

jeff_williams_6
New Contributor II

Just got a new ZD 1200 on firmware 10.1.1.0 build 79

Getting this error after adding google maps api key:

"This site overrides Array.from() with an implementation that doesn't support iterables, which could cause Google Maps JavaScript API v3 to not work correctly."

Any ideas?

1 ACCEPTED SOLUTION

syamantakomer
Moderator
Moderator

Hi Jeff,

Google map API is no longer free to use, hence you have to purchase the map API of your own and then configure it on ZD.

If you don't want to purchase the API and like to hide the map, upgrade to ZD  10.2.1.0.183 (or later), with Admin ability to hide map in the dashboard.

Regards,
Syamantak Omer
Official Rep | Staff TSE | CWNA | CCNA | RASZA | RICXI

View solution in original post

4 REPLIES 4

syamantakomer
Moderator
Moderator

Hi Jeff,

Google map API is no longer free to use, hence you have to purchase the map API of your own and then configure it on ZD.

If you don't want to purchase the API and like to hide the map, upgrade to ZD  10.2.1.0.183 (or later), with Admin ability to hide map in the dashboard.

Regards,
Syamantak Omer
Official Rep | Staff TSE | CWNA | CCNA | RASZA | RICXI

@syamantak_omer

I did purchase it. It works fine except it throws that error every time I open the page. 

@syamantak_omer 

Side note...new firmware fixes this issue...

I'm on 10.2.1.0 build 183

@jeff_williams Good to know recommended version fixed the error.

Regards,
Syamantak Omer
Official Rep | Staff TSE | CWNA | CCNA | RASZA | RICXI