cancel
Showing results for 
Search instead for 
Did you mean: 

Ruckus-Switch VLAN configuration

mayur_javali
New Contributor II
Hi,

I have configured a stand-alone static switch (Cisco 3550) with three DHCP pools associated to different VLANS. Clients connected to vlan 1 would get IP addresses in range of 192.168.0.X, vlan 10 would be in the range of 192.168.1.X & vlan 20 in the range of 192.168.2.X ... Three different interfaces were configured with all three vlans (For Eg: Port 1 with vlan 1, port 2 with vlan 10 & port 3 with vlan 20). The same were tested by connecting a computer to all three ports and was successfully able to obtain a DHCP ip address in the respective range.

However, when i configure my Ruckus access point with the above mentioned vlan for different profiles, it doesn't seem to work. Three different wireless profiles are created viz. Ruckus@1(Vlan 1), Ruckus@2(Vlan 10) & Ruckus @3(Vlan 20).. Ruckus@3 was enabled & was connected to port no 3 of the switch, yet failed to obtain an IP address for my wireless client.. Can anyone let me know in case if i am doing anything wrong at the Access point end as i am sure the switch configuration is correct?

Thanks in advance!
8 REPLIES 8

rahul_koul
Contributor
Hi Mayur,

I believe what you are trying is to have your Access Points broadcast 3 different WLANs viz Ruckus@1, Ruckus@2 & Ruckus @3 for VLANs 1, 10 and 20 respectively.

In order for the clients to get valid Ip address the Access Points need to be connected to Trunk Ports "tagging"(or allowing) the VLANs 1, 10 and 20 and VLAN info has to be added for respective WLANs in ZD WebUI under Configure :: WLANs :: Advanced Options :: Access VLAN. After having done the above mentioned configuration if the clients still do not get valid Ip addresses then please try the below steps:

SSH into the ZD using a terminal client like "Putty" and execute the following commands:

ruckus>en

ruckus#debug

ruckus(debug)# remote_ap_cli -A set qos directedDHCP disable

ruckus(debug)# remote_ap_cli -A get qos

Please let us know if this helps.

Note: I assume you have a Zone Director managing the Access Points.

mayur_javali
New Contributor II
Hi Rahul,

Thanks for your reply. Yes, i tried the steps suggested by you but still failing in getting connected. Let me explain in detail as to what has been done from my end.

A cisco switch has been configured with DHCP settings for three different VLANS and all three works when connected to a PC. I also tried with a plug and play access point which i got it from my home where the AP was broadcasting the respective DHCP IP addresses as when connected to the switch port with respective vlans.

Now, I have connected the ruckus AP to a certain port which is a trunk port and configured with 1,10 & 20 VLAN ids. ZD has been configured and connected to a default access port. Three profiles/SSIDs created in a similar manner as attached (Ruckus@2.4, Ruckus@2.4.1 & Ruckus@2.4.2) As per your suggestion, the mentioned commands were also executed. Please let me know in case i am going wrong at some point. Attached screen shot of putty and ZD configuration is FYR.

Kindly let me know in case of any clarifications needed from my end. Image_ images_messages_5f91c417135b77e24795caa9_6671c1b1eda2b15ae954ab3029f05381_Putty_inline-8b11810d-0f86-46ec-91da-b244b71a9e41-480173006.png1375336092 Image_ images_messages_5f91c417135b77e24795caa9_764aecc7254efbdda2514f31180a3ae9_Ruckus_ZD_inline-37b5d493-5270-4662-81e3-8bc57fa90ec7-1058662099.png1375336105

keith_redfield
Valued Contributor II
Does the fact the Cisco uses vlan 1 (IRRC..) for default come into play here?

mayur_javali
New Contributor II
By default, cisco switches treat VLAN 1 as the default VLAN. The switch, ZD,AP and the end computer are connected to VLAN 1 IP addresses. However, this should not have any impact on the other vlans.

Kindly let me know if your question is still unanswered!
Labels