cancel
Showing results for 
Search instead for 
Did you mean: 

Option 43 does not work with ruckus r300 and Cisco C3750, IP is assigned to r300 but option 43 is not

matej_gololicic
New Contributor II
Option 43 does not work with ruckus r300.

The following is the configuration on Cisco switch:
===================
!
ip dhcp pool alfa
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 192.168.2.1
option 43 hex f104.c0a8.6464
!
Option 43 was configured according to this article: https://support.ruckuswireless.com/an...

If I issue "show ip dhcp bindinds" command on Cisco switch I can see that the connected R300 gets its IP:

Switch#show ip dhcp binding
IP address Client-ID/ Lease expiration Type
Hardware address
192.168.2.2 01e0.107f.3673.90 Mar 02 1993 12:35 AM Automatic
192.168.2.3 0100.21cc.d04d.4f Mar 02 1993 12:35 AM Automatic
Switch#

01e0.107f.3673.90 is R300 MAC address.

I am connected to the same subnet with my PC.
I connect to R300 via SSH session and check DHCP options:
Here's the output. As you can see DHCP option 43 is not set on R300.

OK
rkscli: get director
------ ZoneDirector Info ------
Primary Controller : n/a
Secondary Controller : n/a
DHCP Opt43 Code : 3
AP is in Stand-alone mode.
OK

What do you think is the issue here? I cannot deploy APs if this setting is not working.
Thank you for reply!
14 REPLIES 14

martin_martin
Valued Contributor
Hi Matej,

Please check the dhcp document.

The option 43 should be in hex and without the dots (.)

matej_gololicic
New Contributor II
Hi. I've checked the documentation and set up Cisco switch according to Ruckus document.

Cisco IOS will put dots in values, not me.

Here's how it is configured.

Switch(dhcp-config)#ip dhcp pool alfa
Switch(dhcp-config)#option 43 hex f104c0a86464
Switch(dhcp-config)#end

As you can see I've inputted the value without dots.

When I issue "show running" command on Cisco I get the following output for DHCP:

!
ip dhcp pool alfa
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 192.168.2.1
option 43 hex f104.c0a8.6464
!

It's not me who places the dots. It works as designed.

Is this option 43 even working with r300?
(firmware version is: 9.8.1.0.99)

keith_brown_695
New Contributor
Try it this way and see how it works.
!
ip dhcp pool alfa
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 192.168.2.1
option 43 ascii x.x.x.x
!

martin_martin
Valued Contributor
Did you also exclude teh 192.168.2.1 otherwise that might give a problem as-well.
Labels