Showing results for 
Search instead for 
Did you mean: 

Ruckus Unleashed r500 not working correctly with Google Expeditions

New Contributor III
I have a client who has just half a dozen unleashed r500 Ap's all on the same subnet.
All they want to do is be able to use Google Expeditions so that one ipad can be a Guide and the others as Followers.
The ipads all receive their ip addresses from same DHCP server and all on the same subnet- they are set up on the Master AP as VLAN 1 there are no other VLANs .
The Google Expeditions apps cannot find each other -the idea is that they are all on same wifi network -once the Leader has started the app the followers can find the leader , form an expedition and get exploring.However neither can find each other.
Everything I have read around this advises me to tick the bonjour gateway tick box and allow this between VLANs - however I have been advised that because they have a flat network with no VLANS Bonjour Gateway is not relevant as all broadcast traffic is on the same subnet, so it should just work straight away. The trouble is it doesnt.

Im hoping some /many of you will have experienced this before.
Many thanks in advance

Esteemed Contributor II
Hello Goodday,

Thanks for describing the expected behavior of the app.  It sounds like it's Multicast based.
Ruckus has a Directed Multicast feature, enabled by default, that will give first 5 multicast
members a TCP rather than UDP message, with better delivery expectations.  But in the
case of roaming clients, it sounds like you want this feature to be disabled and we let IGMP
work and flood AP WLANs with client multicasts.

The key is to determine which WLAN interface your Google clients are using, then tell all the
APs to disable the directed multicast feature.  I'll show you how to get this information from
SSH to a Member AP, and the Master AP.

Say your clients are on my WLAN with SSID = SRO-mic.bra-Unl-PSK.  We need to know
what WLAN ID is associated with this SSID, on both radio bands of your APs.  Once we
have this wlanX, we can send a command to all APs thru the Master AP, that they should
disable directed multicast on this SSID, on both radios.

Member AP:
SSH to any Member AP, login with Admin uid/pw:
rkscli:  get wlanlist
Name  Status  Type  wlanID   RadioID   bssid      ssid
wlan0      up       AP    wlan0          0          SRO-mic.bra-Unl-PSK
wlan1      up       AP    wlan1          0          Test-guest-access

wlan32    up       AP    wlan32        1           SRO-mic.bra-Unl-PSK
wlan33    up       AP    wlan33        1           Test-guest-access

Master AP:
SSH to your Master AP, login with Admin uid/pw:
>  en
ruckus#  debug
ruckus (debug): remote_ap_cli -A "set qos wlan0 directed multicast disable"
ruckus (debug): remote_ap_cli -A "set qos wlan32 directed multicast disable"
ruckus (debug): quit
ruckus#  quit

Esteemed Contributor II
I've filed UN-850 Unleashed feature request to have Directed Multicast control added under Edit WLAN, advanced options, either 'Access Control' or 'Other'.

New Contributor III
Thank you very much for taking the time to suggest a solution and for the feature request. I have implemented this tonight and will check it tomorrow . Brilliant!!

New Contributor III
Just to update that my client attempted to use google expeditions today after applying all the changes and it is still not working the devices can not see each other on expeditions. If you could help any further i would be very grateful.