cancel
Showing results for 
Search instead for 
Did you mean: 

How to make “no qos directed-multicast” persist across reboots?

Zuul
New Contributor III

I’m running an R650 (Unleashed 200.9.10.4.233) with a number of wireless Sonos speakers on my network. I’ve applied the fix through the CLI to allow the Sonos controller to see the speakers:


enable

config

wlan MyWifiNetwork

no qos directed-multicast

end

end

Unleashed confirms the settings have been saved.


However whenever I reboot my AP, I have to reapply the fix or my speakers remain unavailable.

How can I make this change persist across reboots?

1 ACCEPTED SOLUTION

syamantakomer
Moderator
Moderator

Hi @derek_fong 

As discussed over the support case, issue is no longer observed on 200.9.10.4.243 version.

Regards,
Syamantak Omer
Official Rep | Staff TSE | CWNA | CCNA | RASZA | RICXI

View solution in original post

14 REPLIES 14

Zuul
New Contributor III

After additional troubleshooting, I've determined that this setting does get saved but does not seem to be applied after the AP restarts so this looks to be a bug to me. I was able to reproduce this with 200.9.10.4.212 as well.

To test this, I ran the commands in the OP on my AP then immediately rebooted it. About 10 minutes after the AP came back up, I was still unable to see my Sonos speakers or my AirPrint printer (both of which use multicast AFAIK).

So I sshed into the AP and got info on my AP:

Welcome to Ruckus Unleashed Network Command Line Interface
ruckus> enable
ruckus# config
You have all rights in this mode.
ruckus(config)# wlan MyWifiNetwork
The WLAN service 'MyWifiNetwork' has been loaded. To save the WLAN service, type 'end' or 'exit'.
ruckus(config-wlan)# show
WLAN Service:
  ID:
    2:
      NAME = MyWifiNetwork
      Tx. Rate of Management Frame(2.4GHz) = 2.0Mbps
      Tx. Rate of Management Frame(5GHz)   = 6.0Mbps
      Beacon Interval = 100ms
      SSID = MyWifiNetwork
      Description = MyWifiNetwork
      Type = Standard Usage
      Authentication = open
      Encryption = wpa2
      Algorithm = aes
      Passphrase = REDACTED
      FT Roaming = Enabled
      802.11k Neighbor report = Enabled
      Web Authentication = Disabled
      Authentication Server = Disabled
      Called-Station-Id type = wlan-bssid
      Tunnel Mode = Disabled
      Background Scanning = Enabled
      Max. Clients = 100
      Isolation per AP = Disabled
      Isolation across AP = Disabled
      Zero-IT Activation = Disabled
      Priority = High
      Load Balancing = Disabled
      Band Balancing = Disabled
      Dynamic PSK = Disabled
      Rate Limiting Uplink = Disabled
      PerSSID Rate Limiting Uplink = 0
      Rate Limiting Downlink = Disabled
      PerSSID Rate Limiting Downlink = 0
      Auto-Proxy configuration:
        Status = Disabled
      Inactivity Timeout:
          Status = Enabled
          Timeout = 1 Minutes
      VLAN-ID = 1
      Dynamic VLAN = Disabled
      Closed System = Disabled
      Https Redirection = Disabled
      OFDM-Only State = Disabled
      Multicast Filter State = Disabled
      Directed Multicast= Disabled
      802.11d State = Enabled
      Force DHCP State = Disabled
      Force DHCP Timeout = 10
      DHCP Option82:
          Status = Disabled
          Option82 sub-Option1 = Disabled
          Option82 sub-Option2 = Disabled
          Option82 sub-Option150 = Disabled
          Option82 sub-Option151 = Disabled
      Ignore unauthorized client statistic = Disabled
      STA Info Extraction State = Enabled
      BSS Minrate = Disabled
      DTIM period = 3
      Directed MC/BC Threshold = 0
      Call Admission Control State = Disabled
      PMK Cache Timeout= 720 minutes
      PMK Cache for Reconnect= Enabled
      NAS-ID Type= wlan-bssid
      Roaming Acct-Interim-Update= Disabled
      PAP Message Authenticator = Enabled
      Send EAP-Failure = Disabled
      L2/MAC = No ACLS
      L3/L4/IP Address = No ACLS
      L3/L4/IPv6 Address = No ACLS
      Precedence = Default
      Proxy ARP = Disabled
      Device Policy = No ACLS
      Vlan Pool = No Pools
      Role based Access Control Policy = Disabled
      SmartRoam = Disabled  Roam-factor = 1
      White List = No ACLS
      URL Filtering = Disabled
      Application Recognition & Control = Enabled
      Apply ARC Policy = NO POLICY
      WIFICalling Enabled= Disabled
      WIFICalling Profile= 0
      Client Flow Data Logging = Disabled
      Wlan Bind = all
      Client Connection Data = Disabled
      Transient Client Management = Disabled
      80211w-pmf = Disabled

ruckus(config-wlan)# exit
The WLAN service 'MyWifiNetwork' has been updated and saved.
Your changes have been saved.
ruckus(config)# exit
Your changes have been saved.
ruckus# exit
Exit ruckus CLI.

So, directed-multicast is marked as disabled.

However, upon exiting (saving changes) with no changes made, I was able to see my AirPrint printer and Sonos speakers within a few seconds.

By simply re-saving the AP configuration with no changes, I was able to get everything working again so this sounds like a bug to me. Should I report this or am I missing something?

syamantakomer
Moderator
Moderator

Hi Derek,

Refer below KBA and see if that helps. If not, feel free to open a case with support and report the issue.

https://support.ruckuswireless.com/articles/000006234

Regards,
Syamantak Omer
Official Rep | Staff TSE | CWNA | CCNA | RASZA | RICXI

Zuul
New Contributor III

Hi Syamantak,

I can't view that article but I can confirm that the issue I reported persists. It seems that simply re-saving the WLAN at the CLI is required to get multicast working properly following a reboot.

Thanks.

Hi Derek,

I just tried accessing the link again and its working for me.

Are you getting any error?

Regards,
Syamantak Omer
Official Rep | Staff TSE | CWNA | CCNA | RASZA | RICXI