Showing results for 
Search instead for 
Did you mean: 

1 of 3 R310’s is underperforming

New Contributor III

Dear community,

I have 3 R310’s in my home, two downstairs and one at the third floor.

Unleashed setup, firmware, wired connected via 1000mbit, PoE af switch (netgear).

Roaming works well on AP’s, but WiFi speed on AP’s downstairs is at max speed (300mbit), WiFi speed on the one upstairs is max 70 mbit (close to AP). WiFi range on this one seems very low as well.

I have checked the performance of the lan cable by connecting my laptop, which is full 1000mbit with no package loss.

What I have searched so far on the forum:

- there seems to be a performance issue (for over two years now), halving download speed compared to max. But this seems unlikely, since 2 of the 3 are performing really well. Option would be to downgrade to 200.4. But then I miss a lot of improvements?

- interference in unleashed network. Could that be the case, since they are transmitting the same radio on the same channel? Seems unlikely as well.

Any help is greatly appreciated!


New Contributor III

Ok, think I fixed it. 

Hard reset of the slow AP did not do anything, so indeed swapped two AP’s.

now the swapped one still not performed at max speed, but a lot better than on the previous location.

then I decoupled the AP on the third floor from the PoE switch (802.3af). Perhaps capacity of the netgear switch was too low. I added the Ruckus PoE injector at the one one the third floor, and all 3 AP’s perform now at max ISP speed (300mbit).

will try for a few more days and let you know the outcomes.

thanks for the help so far!

btw. I previously only enabled channels 36-48, resulting them to stay all on the same 80mhz channel. Now also enabled channels 52-116.

View solution in original post


Contributor III

You might try the swapping location of the under-performer with one of the normal performers. See if the issue moves with the hardware or stays with the location. 

great idea David! Was planning to do so as well 🙂 but let you definitely know the outcomes!


      Also 70mbps sounds like your on the 2.4ghz band..... What device are you have problems with?  Have you tried separating both 2.4ghz and 5ghz SSIDs?  First try swapping as someone suggested then separate 2.4ghz band   and 5ghz band as a test.. Afterwards check your logs...

On what band you have a problem? 

Try  to change channel used.

If performance doesn't improve -- swap the AP (and configure new to use same channels). 

If same result - look for how it is mounted and try to relocate.

Also check performance with same client you used to check other APs.

Performance should be same for all 3 APs, if conditions are not different.