Showing results for 
Search instead for 
Did you mean: 

Ruckus ICX7150-C12 Switch is frequently dropping internet connection

New Contributor

I own a Lennar home that comes with a pre-installed Ruckus ICX7150-C12. I never had issues with the internet connection from the switch until a Spectrum agent came over to my house to replace their modem with another one. Since then, any connection via the ruckus switch, either through ethernet or the unleash wireless access points, has been unstable. Unstable, meaning my browser failing to find the DNS server, videos not loading, etc. My router, a TP-link AC1750, is connected in between the ruckus switch and modem and has no problems connecting to the internet. I've tried resetting the Ruckus Switch via powercycling and factory resetting the TP-link router, but the issues still persist.

I also noticed that the Spectrum representative rearranged my cat6 cables that are connected from the router to the switch. I don't know why he did this, or what else he changed. Currently, the configurations are this: The modem's ethernet cable is connected to the router, and the router's ethernet cable is connected to one of the 10 numbers ethernet ports.

In short, the ruckus switch's connection to my internet has been poor ever since my modem was swapped out for another one. Resetting all three devices (switch, router, modem) doesn't seem to have helped.


Now to fix it... Write down the IP address that the device was assigned. In my case it was

  1. Open a telnet session to the switch. Using bash on Windows worked, or perhaps putty bu the gist is 'telnet', I wasn't able to get the web GUI to work
    1. NOTE: you need to be connected to your ISP gateway or something that's not the ruckus AP because for some reason this doesn't work
  2. 'show flash'
    1. Validate that you see an image with SPS in the primary, in my case it was SPS in the pri (primary) and SPR (router) in tehe sec (secondary)
  3. 'enable'
    1. Enter EXEC mode
  4. 'boot system flash primary'
    1. Tell it to boot to the primary image
  5. 'y'
    1. Agree to boot to the primary

At this point you should get kicked off the telnet session and you should see it change to 'ICX7150-C12 Switch' in the DHCP list and everything should work as normal. I hope this helps other people who encountered this during WFH and banged their heads.

Hi Dylan, can you help me please? I need this same solution but am technology illiterate. How do I open a Telnet session? And the numbers to your steps , e.g. “show flash” , is that something I type? Could you please reply as if you’re explaining to a 2 yo please. I’m desperate for this to get fixed! Thank you!!

In addition I used these commands to backup the current images in flash, then copy my switch image:

  1. enable
  2. show flash
    1. write down the names of the images in parens
  3. copy flash disk0 primary sps08080d.bin
  4. copy flash disk0 secondary spr08080d.bin
  5. copy flash flash secondary

This was very helpful Dylan

In addition to the above commands suggested by Dylan, the Ruckus Support suggested the following.

1. Once you are in the telnet session

2. Switch to EXEC mode using the ENable command

3. "show int b" (this command will show all active ports

Image_ images_messages_60d755aaa52e30294c2a4ee3_84216d84f151307fad1f761827aa5fe4_image-91c175f2-544d-4394-911f-9beca5fc4977-879320330.PNG