Showing results for 
Search instead for 
Did you mean: 

Re: ICX7150-C12P-2X1G not Powering up. Cables burnt inside

New Contributor

What is the link that you used to return?



Hello @Shoats

Warm greetings from RUCKUS Lennar Home Community.

Thank you for reaching out to us. I trust you're doing well.

To assist you effectively, could you please provide a detailed explanation of the issue you're encountering with the RUCKUS devices? Any specific symptoms, error messages, or observations you've noted would be helpful for us to proceed with troubleshooting.

Once we have a clearer understanding of the problem, we'll be able to provide you with appropriate guidance and support.

Thank you for your cooperation and understanding.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community

my Roku switch has no power. I tried to reset it multiple times I even took the plug out and plug it back in and all it does is the amber lights flash and that’s it. And no other lights are on even my access points have no lights. Will I be able to return this for a new one?

Hi @Shoats 


Thank you for contacting RUCKUS Lennar Home Community.

I hope you are doing well!!!

Thank you for the information you shared.

As per the case description, I understand that your RUCKUS ICX-7150-C12P Switch is not powering up and you tried to reset it multiple times.

Please plug your ICX-7150-C12P Switch into a working power outlet and send us PICTURES and VIDEO of it showing the light status, and cord connected to the Switch and a working power outlet. Please refer to the below pictures as an example.

Please use the below link to upload a VIDEO: (Refer to the EXAMPLE VIDEOS from the guide)

Please let me know if you have any queries in this regard.

Thank you again for your patience and understanding. 


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.