Showing results for 
Search instead for 
Did you mean: 

ICX7450 UFI Upgrade Issue

New Contributor

So I have a switch that was on the 08070 firmware which was non UFI. I wanted to upgrade to 09010a UFI so I did a staggered upgrade, first to 08080f non-UFI in both primary and secondary, then to 09010a UFI in both primary and secondary. It seemed to work fine and I have been wanting to factory reset and redo some of my VLAN stuff and just start from scratch. So I ran the "erase system system-defaults" command on both the Switch image in primary and the router image in the secondary. When I ran the command on the second image and reloaded it went to the OS> recovery prompt so I got back to the boot prompt and set up the FTP server on the management port. It would not let me reload any UFI image from uboot. So I had to upload 10114 boot image and them 08080f into the primary and secondary. It then booted and I performed the upgrade again to 09010a and reloaded and it boots fine the first time but anytime now I have to restart the switch after the initial upgrade to the UFI image it goes directly to the OS> recovery prompt and I have to go through the whole process again of recovering and then upgrading to get the switch back up. Hopefully this makes sense. Let me know if anyone has any suggestions. I assume something goes wrong at boot but why would it boot up initially and only after a reboot it fails. Even if I change nothing after upgrading to UFI and just reboot immediately, it goes into recovery. I know this is long winded but I felt the details were necessary. Any help is greatly appreciated. It's driving me crazy. I have it on 09010a now and I have set everything up but I can't reboot.



This sounds like it needs proper investigation. I would recommend opening a support case. If you do not specifically need something in 9010, I would recommend 8090 (specifically 8090mc) code stream as it is the most mature of our active code streams. 


Ben Beck, RCNA, RCNI, Principal Technical Support Engineer