cancel
Showing results for 
Search instead for 
Did you mean: 

2 x 40G LAG on ICX7550 100G ports not allowed?

zotacno
New Contributor

Hi,

Yesterday I was trying to configure a LACP connection using two QSFP+ DAC cables between a Brocade VDX 6740 and an ICX-7550-24ZP. The VDX was no issue to configure, but on the ICX I ran into issues specifying the port-speed. 

I disabled stacking on the ICX and removed the interfaces 1/2/1 and 1/2/2 as stack ports. Then I created a LAG, no problems there either. However, as soon as I specify the speed at 40G, I get the following errors:

lag VDX dynamic id 10
ports ethe 1/2/1 ethe 1/2/2
port-name "Uplink VDX" ethernet 1/2/1
port-name "Uplink VDX" ethernet 1/2/2
!
SSH@demoswitch(config-lag-if-lg10)#speed-duplex 40g-full

INFO: lg10: 40G Speed is applied on 100G port , ensure 40G optics is present
INFO: 1/2/2: 40G Speed is applied on 100G port , ensure 40G optics is present
INFO: lg10: 40G Speed is applied on 100G port , ensure 40G optics is present
Error: Speed 40G can't be supported for 1/2/2 lag member ports, try least common speed

If I don't specify the speed at all, the link will not come up at all. 
For now I removed one of the interfaces from the LAG, and set it up as a single interface and that works fine at 40G.

Am I missing something?  ICX is running 08.0.95d firmware

 

2 REPLIES 2

BenBeck
Moderator
Moderator

Hey @zotacno,

What exact optic are you using? Could you share the output of:

show media eth 1/2/1

show media eth 1/2/2

The switch should detect the 40Gb optic and set the speed automatically; no manual speed setting should be needed. 

 

Ben Beck, RCNA, Principal Technical Support Engineer
support.ruckuswireless.com/contact-us

Hello Ben 

Sorry about the late reply. 

In port 1/2/1 I have a DAC-cable : 40GBASE-Passive Copper 3m (QSFP+)  
Port 1/2/2 is currently empty, but was planning to use a similar DAC cable.

Kind regards